~ubuntu-branches/ubuntu/utopic/libxml2/utopic

« back to all changes in this revision

Viewing changes to debian/patches/0002-fix-python-multiarch-includes.patch

  • Committer: Package Import Robot
  • Author(s): Aron Xu, Christian Svensson, Daniel Schepler, Helmut Grohne, Adam Conrad, Matthias Klose, Aron Xu
  • Date: 2014-07-09 05:40:15 UTC
  • mto: This revision was merged to the branch mainline in revision 75.
  • Revision ID: package-import@ubuntu.com-20140709054015-rdnfjxrf3zvmw6l7
[ Christian Svensson ]
* Do not build-depend on readline (Closes: #742350)

[ Daniel Schepler ]
* Patch to bootstrap without python (Closes: #738080)

[ Helmut Grohne ]
* Drop unneeded B-D on perl and binutils (Closes: #753005)

[ Adam Conrad ]
* Actually run dh_autoreconf, which the old/new mixed rules file misses.

[ Matthias Klose ]
* Add patch to fix python multiarch issue
* Allow the package to cross-build by tweaking B-Ds on python
* Set PYTHON_LIBS for cross builds

[ Aron Xu ]
* Use correct $CC
* Configure udeb without python
* New round of cherry-picking upstream fixes
  - Includes fixes for CVE-2014-0191 (Closes: #747309).
* Call prename with -vf
* Require python-all-dev (>= 2.7.5-5~)
* Bump std-ver: 3.9.4 -> 3.9.5, no change

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Matthias Klose <doko@ubuntu.com>
 
2
Date: Wed, 9 Jul 2014 05:30:24 +0800
 
3
Subject: fix python multiarch includes
 
4
 
 
5
---
 
6
 python/Makefile.am |    2 +-
 
7
 python/Makefile.in |    2 +-
 
8
 2 files changed, 2 insertions(+), 2 deletions(-)
 
9
 
 
10
diff --git a/python/Makefile.am b/python/Makefile.am
 
11
index 34aed96..8445ea5 100644
 
12
--- a/python/Makefile.am
 
13
+++ b/python/Makefile.am
 
14
@@ -19,7 +19,7 @@ if WITH_PYTHON
 
15
 AM_CPPFLAGS = \
 
16
        -I$(top_builddir)/include \
 
17
        -I$(top_srcdir)/include \
 
18
-       -I$(PYTHON_INCLUDES)
 
19
+       $(PYTHON_INCLUDES)
 
20
 
 
21
 python_LTLIBRARIES = libxml2mod.la
 
22
 
 
23
diff --git a/python/Makefile.in b/python/Makefile.in
 
24
index efdea43..23e7fa2 100644
 
25
--- a/python/Makefile.in
 
26
+++ b/python/Makefile.in
 
27
@@ -430,7 +430,7 @@ EXTRA_DIST = \
 
28
 @WITH_PYTHON_TRUE@AM_CPPFLAGS = \
 
29
 @WITH_PYTHON_TRUE@     -I$(top_builddir)/include \
 
30
 @WITH_PYTHON_TRUE@     -I$(top_srcdir)/include \
 
31
-@WITH_PYTHON_TRUE@     -I$(PYTHON_INCLUDES)
 
32
+@WITH_PYTHON_TRUE@     $(PYTHON_INCLUDES)
 
33
 
 
34
 @WITH_PYTHON_TRUE@python_LTLIBRARIES = libxml2mod.la
 
35
 @WITH_PYTHON_TRUE@libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c