~ubuntu-branches/ubuntu/utopic/mdadm/utopic

« back to all changes in this revision

Viewing changes to debian/patches/sha1-includes.diff

  • Committer: Package Import Robot
  • Author(s): Dmitrijs Ledkovs
  • Date: 2012-06-15 15:31:59 UTC
  • mfrom: (1.1.30 sid)
  • Revision ID: package-import@ubuntu.com-20120615153159-9lp7jykbq7vua4bo
Tags: 3.2.5-1ubuntu1
* Merge from Debian testing. (LP: #920324)  Remaining changes:
  - Call checks in local-premount to avoid race condition with udev
    and opening a degraded array.
  - d/initramfs/mdadm-functions: Record in /run when boot-degraded 
    question has been asked so that it is only asked once
  - pass --test to mdadm to enable result codes for degraded arrays. 
  - debian/control: we need udev and util-linux in the right version. We
    also remove the build dependency from quilt and docbook-to-man as both
    are not used in Ubuntus mdadm.
  - debian/initramfs/hook: kept the Ubuntus version for handling the absence
    of active raid arrays in <initramfs>/etc/mdadm/mdadm.conf
  - debian/initramfs/script.local-top.DEBIAN, debian/mdadm-startall,
    debian/mdadm.raid.DEBIAN: removed. udev does its job now instead.
  - debian/mdadm-startall.sgml, debian/mdadm-startall.8: documentation of
    unused startall script
  - debian/mdadm.config, debian/mdadm.postinst - let udev do the handling
    instead. Resolved merge conflict by keeping Ubuntu's version.
  - debian/mdadm.postinst, debian/mdadm.config, initramfs/init-premount:
    boot-degraded enablement; maintain udev starting of RAID devices;
    init-premount hook script for the initramfs, to provide information at
    boot
  - debian/mkconf.in is the older mkconf. Kept the Ubuntu version.
  - debian/rules: Kept Ubuntus version for installing apport hooks, not
    installing un-used startall script.
  - debian/install-rc, check.d/_numbers, check.d/root_on_raid: Ubuntu partman
    installer changes
  - debian/presubj: Dropped this unused bug reporting file. Instead use
    source_mdadm.py act as an apport hook for bug handling.
  - d/p/debian-changes-3.1.4-1+8efb9d1ubuntu4: mdadm udev rule
    incrementally adds mdadm member when detected. Starting such an
    array in degraded mode is possible by mdadm -IRs. Using mdadm
    -ARs without stopping the array first does nothing when no
    mdarray-unassociated device is available. Using mdadm -IRs to
    start a previously partially assembled array through incremental
    mode. Keeping the mdadm -ARs for assembling arrays which were for
    some reason not assembled through incremental mode (i.e through
    mdadm's udev rule).

* Additional Ubuntu changes:
    - debian/initramfs/local-premount: add call wait_for_udev to wait a
    little longer for RAID devices to appear (LP: #942106)

* Dropped Ubuntu changes:
  - Build udeb with -O2 on ppc64, working around a link error. Builds
    fine without it on debian.
  - rename debian/mdadm.vol_id.udev to debian/mdadm.mdadm-blkid.udev so
    that the rules file ends up with a more reasonable name. debian/rules
    changes for adding ubuntu's udev rule corresponding to mdadm. As we
    are now using 'upstream' udev rules see 3.2.3-2ubuntu2.

* Changes to Ubuntu changes:
  - debian/source_mdadm.py: make apport hook python 2 and 3 compatible
    (LP: #1013171).

* New upstream release closes this bugs:
  - mdadm --detail --scan segfaults during update-initramfs (LP: #969384)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Michael Tokarev <mjt@tls.msk.ru>
 
2
Subject: do not #include ansidecl.h from sha1.h, use system headers
 
3
 
 
4
In 3.2.5 version of mdadm, new sha1 implementation has been included
 
5
which tries to include ansidecl.h header which is internal to some
 
6
other project.  But this #include isn't really necessary, since this
 
7
implementation does not actually use any defines from ansidecl.h.  So
 
8
just remove the #include, instead of adding a new external dependency.
 
9
 
 
10
References: http://www.spinics.net/lists/raid/msg38859.html
 
11
 
 
12
While at it, unconditionally include system headers like limits.h and
 
13
stdint.h, since on a Linux system these headers are available, and
 
14
these contains definitive information about real system types than
 
15
any guesses.
 
16
 
 
17
--- a/sha1.h
 
18
+++ b/sha1.h
 
19
@@ -22,12 +22,10 @@
 
20
 
 
21
 #include <stdio.h>
 
22
 
 
23
-#if defined HAVE_LIMITS_H || _LIBC
 
24
+#if 1 /* defined HAVE_LIMITS_H || _LIBC */
 
25
 # include <limits.h>
 
26
 #endif
 
27
 
 
28
-#include "ansidecl.h"
 
29
-
 
30
 /* The following contortions are an attempt to use the C preprocessor
 
31
    to determine an unsigned integral type that is 32 bits wide.  An
 
32
    alternative approach is to use autoconf's AC_CHECK_SIZEOF macro, but
 
33
@@ -35,9 +33,9 @@
 
34
    the resulting executable.  Locally running cross-compiled executables
 
35
    is usually not possible.  */
 
36
 
 
37
-#ifdef _LIBC
 
38
-# include <sys/types.h>
 
39
-typedef u_int32_t sha1_uint32;
 
40
+#if 1 /* def _LIBC */
 
41
+# include <stdint.h>
 
42
+typedef uint32_t sha1_uint32;
 
43
 typedef uintptr_t sha1_uintptr;
 
44
 #else
 
45
 #  define INT_MAX_32_BITS 2147483647