~ubuntu-branches/ubuntu/utopic/mutagen/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/undefined-name

  • Committer: Package Import Robot
  • Author(s): Daniel T Chen
  • Date: 2013-11-27 22:10:48 UTC
  • mfrom: (8.1.17 sid)
  • Revision ID: package-import@ubuntu.com-20131127221048-ae2f5j42ak2ox3kw
Tags: 1.22-1ubuntu1
* Merge from Debian unstable.  Remaining changes:
  - debian/control: Drop faad and oggz-tools build dependencies (in
    universe).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix undefined name in EasyID3
2
 
Origin: upstream, http://code.google.com/p/mutagen/source/detail?r=c6a143d85dc7eafe658821fcf61e70aff775a6cc
3
 
 
4
 
--- mutagen-1.21.orig/mutagen/easyid3.py
5
 
+++ mutagen-1.21/mutagen/easyid3.py
6
 
@@ -176,7 +176,7 @@ class EasyID3(DictMixin, Metadata):
7
 
                         lambda s, fn: setattr(s.__id3, 'filename', fn))
8
 
 
9
 
     size = property(lambda s: s.__id3.size,
10
 
-                    lambda s, fn: setattr(s.__id3, 'size', v))
11
 
+                    lambda s, fn: setattr(s.__id3, 'size', s))
12
 
 
13
 
     def __getitem__(self, key):
14
 
         key = key.lower()