~ubuntu-branches/ubuntu/utopic/nordugrid-arc/utopic

« back to all changes in this revision

Viewing changes to debian/patches/nordugrid-arc-cred-test.patch

  • Committer: Package Import Robot
  • Author(s): Mattias Ellert
  • Date: 2014-05-01 20:51:02 UTC
  • mfrom: (1.1.11)
  • Revision ID: package-import@ubuntu.com-20140501205102-icy9t3348uxobyx7
Tags: 4.1.0-1
* 4.1.0 Release
* Call dh_autoreconf to support ppc64le (Closes: #744639)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ur nordugrid-arc-4.1.0.orig/src/hed/libs/credential/test/Makefile.am nordugrid-arc-4.1.0/src/hed/libs/credential/test/Makefile.am
 
2
--- nordugrid-arc-4.1.0.orig/src/hed/libs/credential/test/Makefile.am   2012-11-19 12:51:41.850498000 +0100
 
3
+++ nordugrid-arc-4.1.0/src/hed/libs/credential/test/Makefile.am        2014-05-02 13:12:52.670485802 +0200
 
4
@@ -5,11 +5,11 @@
 
5
 
 
6
 CredentialTest_SOURCES = $(top_srcdir)/src/Test.cpp CredentialTest.cpp
 
7
 CredentialTest_CXXFLAGS = -I$(top_srcdir)/include \
 
8
-       $(CPPUNIT_CFLAGS) $(GLIBMM_CFLAGS) $(LIBXML2_CFLAGS) $(AM_CXXFLAGS)
 
9
+       $(CPPUNIT_CFLAGS) $(GLIBMM_CFLAGS) $(LIBXML2_CFLAGS) $(OPENSSL_CFLAGS) $(AM_CXXFLAGS)
 
10
 CredentialTest_LDADD = \
 
11
        $(top_builddir)/src/hed/libs/credential/libarccredential.la \
 
12
        $(top_builddir)/src/hed/libs/common/libarccommon.la \
 
13
-       $(CPPUNIT_LIBS) $(GLIBMM_LIBS) $(LIBXML2_LIBS)
 
14
+       $(CPPUNIT_LIBS) $(GLIBMM_LIBS) $(LIBXML2_LIBS) $(OPENSSL_LIBS)
 
15
 
 
16
 VOMSUtilTest_SOURCES = $(top_srcdir)/src/Test.cpp VOMSUtilTest.cpp
 
17
 VOMSUtilTest_CXXFLAGS = -I$(top_srcdir)/include \
 
18
diff -ur nordugrid-arc-4.1.0.orig/src/hed/libs/infosys/test/Makefile.am nordugrid-arc-4.1.0/src/hed/libs/infosys/test/Makefile.am
 
19
--- nordugrid-arc-4.1.0.orig/src/hed/libs/infosys/test/Makefile.am      2012-12-03 12:40:33.012505000 +0100
 
20
+++ nordugrid-arc-4.1.0/src/hed/libs/infosys/test/Makefile.am   2014-05-02 23:23:30.478593312 +0200
 
21
@@ -7,7 +7,7 @@
 
22
        $(CPPUNIT_CFLAGS) $(GLIBMM_CFLAGS) $(LIBXML2_CFLAGS) $(AM_CXXFLAGS)
 
23
 InformationInterfaceTest_LDADD = \
 
24
        $(top_builddir)/src/hed/libs/common/libarccommon.la \
 
25
-       ../libarcinfosys.la $(CPPUNIT_LIBS)
 
26
+       ../libarcinfosys.la $(CPPUNIT_LIBS) $(GLIBMM_LIBS)
 
27
 
 
28
 InfoFilterTest_SOURCES = $(top_srcdir)/src/Test.cpp InfoFilterTest.cpp
 
29
 InfoFilterTest_CXXFLAGS = -I$(top_srcdir)/include \
 
30
@@ -15,7 +15,7 @@
 
31
 InfoFilterTest_LDADD = \
 
32
        $(top_builddir)/src/hed/libs/message/libarcmessage.la \
 
33
        $(top_builddir)/src/hed/libs/common/libarccommon.la \
 
34
-       ../libarcinfosys.la $(CPPUNIT_LIBS)
 
35
+       ../libarcinfosys.la $(CPPUNIT_LIBS) $(GLIBMM_LIBS)
 
36
 
 
37
 RegisteredServiceTest_SOURCES = $(top_srcdir)/src/Test.cpp \
 
38
        RegisteredServiceTest.cpp
 
39
@@ -25,4 +25,4 @@
 
40
        ../libarcinfosys.la \
 
41
        $(top_builddir)/src/hed/libs/common/libarccommon.la \
 
42
        $(top_builddir)/src/hed/libs/message/libarcmessage.la \
 
43
-       $(CPPUNIT_LIBS)
 
44
+       $(CPPUNIT_LIBS) $(GLIBMM_LIBS)