~ubuntu-branches/ubuntu/utopic/openssl/utopic

« back to all changes in this revision

Viewing changes to debian/patches/ssltest_no_sslv2.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2014-01-08 15:57:24 UTC
  • mfrom: (11.1.46 sid)
  • Revision ID: package-import@ubuntu.com-20140108155724-kl61on9fyqmod2z9
Tags: 1.0.1f-1ubuntu1
* Merge with Debian, remaining changes.
  - debian/libssl1.0.0.postinst:
    + Display a system restart required notification on libssl1.0.0
      upgrade on servers.
    + Use a different priority for libssl1.0.0/restart-services depending
      on whether a desktop, or server dist-upgrade is being performed.
  - debian/{libssl1.0.0-udeb.dirs, control, rules}: Create
    libssl1.0.0-udeb, for the benefit of wget-udeb (no wget-udeb package
    in Debian).
  - debian/{libcrypto1.0.0-udeb.dirs, libssl1.0.0.dirs, libssl1.0.0.files,
    rules}: Move runtime libraries to /lib, for the benefit of
    wpasupplicant.
  - debian/patches/perlpath-quilt.patch: Don't change perl #! paths under
    .pc.
  - debian/rules:
    + Don't run 'make test' when cross-building.
    + Use host compiler when cross-building.  Patch from Neil Williams.
    + Don't build for processors no longer supported: i586 (on i386)
    + Fix Makefile to properly clean up libs/ dirs in clean target.
    + Replace duplicate files in the doc directory with symlinks.
  - debian/control: Mark Debian Vcs-* as XS-Debian-Vcs-*
  - debian/patches/ubuntu_deb676533_arm_asm.patch: Enable arm assembly
    code.
  - debian/rules: Enable optimized 64bit elliptic curve code contributed
    by Google.
* Dropped changes:
  - debian/patches/arm64-support: included in debian-targets.patch
  - debian/patches/no_default_rdrand.patch: upstream
  - debian/patches/openssl-1.0.1e-env-zlib.patch: zlib is now completely
    disabled in debian/rules

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Dr. Stephen Henson <steve@openssl.org>
2
 
Date: Mon Feb 11 18:17:50 2013 +0000
3
 
Origin: upstream, commit:cbf9b4aed3e209fe8a39e1d6f55aaf46d1369dc4
4
 
Subject: Fix in ssltest is no-ssl2 configured
5
 
 
6
 
diff --git a/ssl/ssltest.c b/ssl/ssltest.c
7
 
index 316bbb0..4f80be8 100644
8
 
--- a/ssl/ssltest.c
9
 
+++ b/ssl/ssltest.c
10
 
@@ -881,7 +881,13 @@ bad:
11
 
                meth=SSLv23_method();
12
 
 #else
13
 
 #ifdef OPENSSL_NO_SSL2
14
 
-       meth=SSLv3_method();
15
 
+       if (tls1)
16
 
+               meth=TLSv1_method();
17
 
+       else
18
 
+       if (ssl3)
19
 
+               meth=SSLv3_method();
20
 
+       else
21
 
+               meth=SSLv23_method();
22
 
 #else
23
 
        meth=SSLv2_method();
24
 
 #endif