~ubuntu-branches/ubuntu/utopic/openvpn/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/clean_netlist.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2011-12-31 04:55:56 UTC
  • mfrom: (1.1.18) (10.2.16 sid)
  • Revision ID: package-import@ubuntu.com-20111231045556-3fwmrbggevr9iqxd
Tags: 2.2.1-3ubuntu1
* Merge from Debian testing.  Remaining changes:
 + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()
  + debian/update-resolv-conf: Support multiple domains.
  + fix bug where '--script-security 2' would be passed for all
    daemons after the first. (LP: #794916)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix random creation of routes when using 'remote_host' option.
2
 
Author: Upstream
3
 
Bug-Debian: http://bugs.debian.org/600166
4
 
Index: openvpn-2.2.0/route.c
5
 
===================================================================
6
 
--- openvpn-2.2.0.orig/route.c  2011-05-10 16:30:14.928001206 +0200
7
 
+++ openvpn-2.2.0/route.c       2011-05-10 16:34:41.432001310 +0200
8
 
@@ -432,6 +432,8 @@
9
 
 
10
 
         CLEAR(netlist);                /* init_route() will not always init this */
11
 
 
12
 
+       CLEAR(netlist);                /* init_route() will not always init this */
13
 
+
14
 
        if (!init_route (&r,
15
 
                         &netlist,
16
 
                         &opt->routes[i],