~ubuntu-branches/ubuntu/utopic/pacemaker/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/prevent_glib_assertion.patch

  • Committer: Package Import Robot
  • Author(s): Liam Young
  • Date: 2014-08-01 15:27:42 UTC
  • mfrom: (2.1.25 sid)
  • Revision ID: package-import@ubuntu.com-20140801152742-7crx0jtcwz4k2l45
Tags: 1.1.10+git20130802-4ubuntu1
* Merge from Debian unstable (LP: #1351307).  Remaining changes:
  - debian/control: Build-Depends on libcfg-dev; Depends on libheartbeat2.
* Corosync's pacemaker plugin is disabled, hence not built:
  - debian/licrmcluster4-dev.install: Do not install plugin.h.
  - debian/pacemaker.install: Do not install pacemaker.lcrso.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/lib/services/systemd.c b/lib/services/systemd.c
 
2
index 2a66da5..b18f86f 100644
 
3
--- a/lib/services/systemd.c
 
4
+++ b/lib/services/systemd.c
 
5
@@ -478,7 +478,10 @@ struct unit_info {
 
6
             fclose(file_strm);
 
7
         }
 
8
         systemd_daemon_reload(systemd_proxy, &error);
 
9
-        g_error_free(error); error = NULL;
 
10
+        if(error) {
 
11
+            g_error_free(error);
 
12
+            error = NULL;
 
13
+        }
 
14
         free(override_file);
 
15
         free(override_dir);
 
16