~ubuntu-branches/ubuntu/utopic/ttf-wqy-zenhei/utopic

« back to all changes in this revision

Viewing changes to debian/patches/02_add_new_alias_settings.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Arne Goetje
  • Date: 2008-02-22 21:41:52 UTC
  • Revision ID: james.westby@ubuntu.com-20080222214152-3fd3d0skrq4fscqc
Tags: 0.4.23-1ubuntu1
* Patch 02_add_new_alias_settings: add this font to be preferred for 
  sans-serif and monospace, before all other non-latin fonts. This patch
  is intended for the Ubuntu desktop to have this font as the default
  sans-serif compatible CJK font. The settings may be overidden by
  language-selector for locales which don't want to use this font.
* Set the XSBC-Original-Maintainer header and updated the Maintainer header.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02_add_new_alias_settings.dpatch by  <arne@mobile.goetje-online.de>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad ttf-wqy-zenhei-0.4.23~/44-wqy-zenhei.conf ttf-wqy-zenhei-0.4.23/44-wqy-zenhei.conf
 
9
--- ttf-wqy-zenhei-0.4.23~/44-wqy-zenhei.conf   2008-02-22 21:50:01.000000000 +0800
 
10
+++ ttf-wqy-zenhei-0.4.23/44-wqy-zenhei.conf    2008-02-22 21:50:02.000000000 +0800
 
11
@@ -15,4 +15,8 @@
 
12
         <edit name="rgba" mode="assign"><const>none</const></edit>
 
13
         <edit name="embeddedbitmap"><bool>false</bool></edit>
 
14
   </match>
 
15
+  <alias>
 
16
+       <family>WenQuanYi Zen Hei</family>
 
17
+       <default><family>sans-serif</family></default>
 
18
+  </alias>
 
19
 </fontconfig>
 
20
diff -urNad ttf-wqy-zenhei-0.4.23~/63-wqy-zenhei.conf ttf-wqy-zenhei-0.4.23/63-wqy-zenhei.conf
 
21
--- ttf-wqy-zenhei-0.4.23~/63-wqy-zenhei.conf   1970-01-01 08:00:00.000000000 +0800
 
22
+++ ttf-wqy-zenhei-0.4.23/63-wqy-zenhei.conf    2008-02-22 21:50:38.000000000 +0800
 
23
@@ -0,0 +1,16 @@
 
24
+<?xml version="1.0"?>
 
25
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
 
26
+<fontconfig>
 
27
+       <alias>
 
28
+               <family>sans-serif</family>
 
29
+               <prefer>
 
30
+                       <family>WenQuanYi Zen Hei</family>
 
31
+               </prefer>
 
32
+       </alias>
 
33
+       <alias>
 
34
+               <family>monospace</family>
 
35
+               <prefer>
 
36
+                       <family>WenQuanYi Zen Hei</family>
 
37
+               </prefer>
 
38
+       </alias>
 
39
+</fontconfig>
 
40
diff -urNad ttf-wqy-zenhei-0.4.23~/debian/rules ttf-wqy-zenhei-0.4.23/debian/rules
 
41
--- ttf-wqy-zenhei-0.4.23~/debian/rules 2008-02-12 16:35:54.000000000 +0800
 
42
+++ ttf-wqy-zenhei-0.4.23/debian/rules  2008-02-22 21:50:02.000000000 +0800
 
43
@@ -26,7 +26,9 @@
 
44
        dh_clean -k 
 
45
        dh_install wqy-zenhei.ttf usr/share/fonts/truetype/wqy/
 
46
        dh_install 44-wqy-zenhei.conf etc/fonts/conf.avail/
 
47
+       dh_install 63-wqy-zenhei.conf etc/fonts/conf.avail/
 
48
        dh_link etc/fonts/conf.avail/44-wqy-zenhei.conf etc/fonts/conf.d/44-wqy-zenhei.conf
 
49
+       dh_link etc/fonts/conf.avail/63-wqy-zenhei.conf etc/fonts/conf.d/63-wqy-zenhei.conf
 
50
 
 
51
 binary-indep: build install
 
52
        dh_testdir