~ubuntu-branches/ubuntu/utopic/wpasupplicant/utopic

« back to all changes in this revision

Viewing changes to debian/patches/05_qmake_version_makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): Kel Modderman
  • Date: 2010-02-27 11:30:53 UTC
  • mfrom: (5.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20100227113053-axxieaw3hmuqbqls
Tags: 0.6.10-2
* Switch to source format 3.0 (quilt), drop quilt build dependency
  and remove '--with quilt' from dh command in debian/rules.
* Fix "FTBFS on kfreebsd-gnu" with addition of 21_kfreebsd.patch.
  Thanks to work by Stefan Lippers-Hollmann and Petr Salinger.
  (Closes: #480572)
* Disable experimental feature CONFIG_IEEE80211W (management frame
  protection) due to it not being supported by any driver but ath9k
  and it generating ioctl errors which cause much concern among users
  for little to no benefit.
* Add traling blank line to debian/NEWS to assist apt-listchanges as
  per lintian advice.
* Cherry pick 30_cfg80211_association_optimisation.patch from upstream
  git. Add cfg80211-specific optimization to avoid silly behavior.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Kel Modderman <kel@otaku42.de>
2
 
Reference: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=463547
3
 
Description: fix FTBFS if both qt3 and qt4 are installed
4
 
 invoke versioned qmake binary when preparing the Makefile for
5
 
 wpa_gui/wpa_gui-qt4 or else a failure to build from source can be possible
6
 
 when more than one QT version is installed.
7
 
 
8
 
--- a/wpa_supplicant/Makefile
9
 
+++ b/wpa_supplicant/Makefile
10
 
@@ -1160,13 +1160,13 @@ windows-bin: $(WINALL)
11
 
        $(STRIP) $(WINALL)
12
 
 
13
 
 wpa_gui/Makefile:
14
 
-       qmake -o wpa_gui/Makefile wpa_gui/wpa_gui.pro 
15
 
+       qmake-qt3 -o wpa_gui/Makefile wpa_gui/wpa_gui.pro
16
 
 
17
 
 wpa_gui: wpa_gui/Makefile
18
 
        $(MAKE) -C wpa_gui
19
 
 
20
 
 wpa_gui-qt4/Makefile:
21
 
-       qmake -o wpa_gui-qt4/Makefile wpa_gui-qt4/wpa_gui.pro 
22
 
+       qmake-qt4 -o wpa_gui-qt4/Makefile wpa_gui-qt4/wpa_gui.pro
23
 
 
24
 
 wpa_gui-qt4: wpa_gui-qt4/Makefile
25
 
        $(MAKE) -C wpa_gui-qt4