~ubuntu-branches/ubuntu/utopic/wxwidgets2.8/utopic

« back to all changes in this revision

Viewing changes to debian/patches/wxstatictext-rtl-alignright.patch

  • Committer: Package Import Robot
  • Author(s): Benjamin Drung
  • Date: 2012-06-02 12:33:00 UTC
  • mfrom: (5.1.15 sid)
  • Revision ID: package-import@ubuntu.com-20120602123300-cmj36sgxk0zi6k0h
Tags: 2.8.12.1-11ubuntu1
* Merge from Debian unstable. Remaining changes:
  - debian/rules: re-enable mediactrl. This allows libwx_gtk2u_media-2.8 to be
    built, as this is required by some applications (LP: #632984)
  - debian/control:
    - Build-dep on libxt-dev, libgstreamer-plugins-base0.10-dev,
      and libgconf2-dev for mediactrl.
    - Add conflict on python-wxgtk2.8 (<< 2.8.12.1-6ubuntu1~) to
      python-wxversion to guarantee upgrade ordering when moving from
      pycentral to dh_python2.
* Drop fix-bashism-in-example.patch. (LP: #1005609)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix wxALIGN_RIGHT in RTL mode
 
2
Author: PC
 
3
Bug: http://trac.wxwidgets.org/ticket/13469
 
4
Applied-Upstream: http://trac.wxwidgets.org/changeset/69201
 
5
Last-Update: 2012-06-01
 
6
 
 
7
Index: wxWidgets/branches/WX_2_8_BRANCH/src/gtk/stattext.cpp
 
8
===================================================================
 
9
--- a/src/gtk/stattext.cpp (revision 52973)
 
10
+++ b/src/gtk/stattext.cpp (revision 69201)
 
11
@@ -78,5 +78,5 @@
 
12
          if (justify == GTK_JUSTIFY_RIGHT)
 
13
             justify = GTK_JUSTIFY_LEFT;
 
14
-         if (justify == GTK_JUSTIFY_LEFT)
 
15
+         else if (justify == GTK_JUSTIFY_LEFT)
 
16
             justify = GTK_JUSTIFY_RIGHT;
 
17
     }