~ubuntu-branches/ubuntu/vivid/atomix/vivid

« back to all changes in this revision

Viewing changes to debian/patches/about.patch

  • Committer: Package Import Robot
  • Author(s): Logan Rosen
  • Date: 2014-12-04 23:47:09 UTC
  • mfrom: (2.1.7 vivid-proposed)
  • Revision ID: package-import@ubuntu.com-20141204234709-pj7v0k2dhv1nfb0o
Tags: 2.14.0-5ubuntu1
* debian/patches/underlinking.diff: Restore Robie Basak's patch from
  2.14.0-2ubuntu2 to build with -lm to fix an underlinking FTBFS.
* Use dh-autoreconf so that the patch is applied.
* Remove unnecessary -lm addition in debian/rules for LDFLAGS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: use convenience function for about dialog and fix close button
 
2
Origin: other, https://bugs.launchpad.net/ubuntu/+source/atomix/+bug/173772
 
3
Author: Marshall Scorcio <marshall.scorcio@gmail.com>
 
4
Acked-By: Petter Reinholdtsen <pere@debian.org>
 
5
Reviewed-By: Guilherme de Siqueira Pastore <gpastore@debian.org>
 
6
Bug-Debian: http://bugs.debian.org/495714
 
7
Last-Update: 2013-02-02
 
8
 
 
9
---
 
10
 src/main.c |   21 +++++++++------------
 
11
 1 file changed, 9 insertions(+), 12 deletions(-)
 
12
 
 
13
diff --git a/src/main.c b/src/main.c
 
14
index 0b2dd2a..016c9b4 100644
 
15
--- a/src/main.c
 
16
+++ b/src/main.c
 
17
@@ -152,8 +152,6 @@ static void verb_EditPreferences_cb (BonoboUIComponent * uic,
 
18
 static void verb_HelpAbout_cb (BonoboUIComponent *uic, gpointer user_data,
 
19
                               const char *cname)
 
20
 {
 
21
-  GtkWidget *dlg;
 
22
-
 
23
   const char *authors[] =
 
24
     {
 
25
       "Guilherme de S. Pastore <gpastore@gnome.org>",
 
26
@@ -167,16 +165,15 @@ static void verb_HelpAbout_cb (BonoboUIComponent *uic, gpointer user_data,
 
27
       NULL
 
28
     };
 
29
 
 
30
-  dlg = gtk_about_dialog_new ();
 
31
-  gtk_about_dialog_set_name (GTK_ABOUT_DIALOG(dlg), "Atomix");
 
32
-  gtk_about_dialog_set_version (GTK_ABOUT_DIALOG(dlg), VERSION);
 
33
-  gtk_about_dialog_set_comments (GTK_ABOUT_DIALOG(dlg), _("A puzzle game about atoms and molecules"));
 
34
-  gtk_about_dialog_set_website (GTK_ABOUT_DIALOG(dlg), "http://www.gnome.org/projects/atomix");
 
35
-  gtk_about_dialog_set_authors (GTK_ABOUT_DIALOG(dlg), authors);
 
36
-  gtk_about_dialog_set_artists (GTK_ABOUT_DIALOG(dlg), artists);
 
37
-  gtk_about_dialog_set_translator_credits (GTK_ABOUT_DIALOG(dlg), _("translator-credits"));
 
38
-
 
39
-  gtk_widget_show (dlg);
 
40
+  gtk_show_about_dialog(GTK_WINDOW(app->mainwin),
 
41
+                                       "program-name", _("Atomix"),
 
42
+                                       "version", VERSION,
 
43
+                                       "comments", _("A puzzle game about atoms and molecules"),
 
44
+                                       "website",_("http://wiki.debian.org/Games/Atomix"),
 
45
+                                       "authors", authors,
 
46
+                                       "artists", artists,
 
47
+                                       "translator_credits", _("translator-credits"),
 
48
+                                       NULL);
 
49
 }
 
50
 
 
51
 static gboolean on_app_destroy_event (GtkWidget *widget, GdkEvent *event,