~ubuntu-branches/ubuntu/vivid/curl/vivid

« back to all changes in this revision

Viewing changes to debian/patches/gnutls

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Schuldei
  • Date: 2009-04-02 23:35:45 UTC
  • mfrom: (1.1.12 upstream)
  • mto: (3.3.1 squeeze)
  • mto: This revision was merged to the branch mainline in revision 38.
  • Revision ID: james.westby@ubuntu.com-20090402233545-8xjr3o2sgce5s4bg
Tags: 7.19.4-1
* New upstream release
* Fix "newer bdb version" <explain what you changed and why> 
  (Closes: #517277)
* resolve libtool version confusion, thanks to 
  Stefanos Harhalakis <v13@v13.gr>
* add new dependency on libgcrypt11-dev due to newly arising binary symbols

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: curl/lib/Makefile.am
2
2
===================================================================
3
 
--- curl.orig/lib/Makefile.am   2008-06-04 19:03:05.000000000 +0200
4
 
+++ curl/lib/Makefile.am        2008-06-04 19:03:05.000000000 +0200
5
 
@@ -39,7 +39,7 @@
 
3
--- curl.orig/lib/Makefile.am   2009-04-03 10:32:03.000000000 +0200
 
4
+++ curl/lib/Makefile.am        2009-04-03 10:32:03.000000000 +0200
 
5
@@ -40,7 +40,7 @@
6
6
 
7
7
 CLEANFILES = $(DSP) $(VCPROJ)
8
8
 
10
10
+lib_LTLIBRARIES = libcurl-gnutls.la
11
11
 LIBCURL_LIBS = @LIBCURL_LIBS@
12
12
 
13
 
 # we use srcdir/include for the static global include files
14
 
@@ -95,12 +95,12 @@
 
13
 # Specify our include paths here, and do it relative to $(top_srcdir) and
 
14
@@ -101,12 +101,12 @@
15
15
 VERSIONED_SYMBOLS = -Wl,--version-script=libcurl.vers
16
16
 endif
17
17
 
18
 
-libcurl_la_LDFLAGS = $(UNDEF) $(VERSION) $(MIMPURE) $(LIBCURL_LIBS) $(VERSIONED_SYMBOLS)
19
 
+libcurl_gnutls_la_LDFLAGS = $(UNDEF) $(VERSION) $(MIMPURE) $(LIBCURL_LIBS) $(VERSIONED_SYMBOLS)
 
18
-libcurl_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS) $(VERSIONED_SYMBOLS)
 
19
+libcurl_gnutls_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS) $(VERSIONED_SYMBOLS)
20
20
 
21
21
 # Makefile.inc provides the CSOURCES and HHEADERS defines
22
22
 include Makefile.inc
28
28
 WIN32HEADERS = $(HHEADERS) config-win32.h
29
29
Index: curl/src/Makefile.am
30
30
===================================================================
31
 
--- curl.orig/src/Makefile.am   2008-06-04 19:03:00.000000000 +0200
32
 
+++ curl/src/Makefile.am        2008-06-04 19:03:05.000000000 +0200
33
 
@@ -37,8 +37,8 @@
 
31
--- curl.orig/src/Makefile.am   2009-04-03 10:20:11.000000000 +0200
 
32
+++ curl/src/Makefile.am        2009-04-03 10:32:03.000000000 +0200
 
33
@@ -45,8 +45,8 @@
34
34
 
35
35
 include Makefile.inc
36
36
 
43
43
 # Use the C locale to ensure that only ASCII characters appear in the
44
44
Index: curl/tests/libtest/Makefile.am
45
45
===================================================================
46
 
--- curl.orig/tests/libtest/Makefile.am 2008-06-04 19:03:00.000000000 +0200
47
 
+++ curl/tests/libtest/Makefile.am      2008-06-04 19:03:05.000000000 +0200
48
 
@@ -51,8 +51,8 @@
49
 
   lib544 lib545 lib547 lib548 lib549 lib552 lib553 lib554 lib555 lib556
 
46
--- curl.orig/tests/libtest/Makefile.am 2009-04-03 10:20:12.000000000 +0200
 
47
+++ curl/tests/libtest/Makefile.am      2009-04-03 10:32:03.000000000 +0200
 
48
@@ -56,8 +56,8 @@
 
49
   lib539 lib557 lib558 lib559 lib560
50
50
 
51
51
 # Dependencies (may need to be overriden)
52
52
-LDADD = $(LIBDIR)/libcurl.la
58
58
 lib500_SOURCES = lib500.c $(SUPPORTFILES)
59
59
Index: curl/docs/examples/Makefile.am
60
60
===================================================================
61
 
--- curl.orig/docs/examples/Makefile.am 2008-06-04 19:03:01.000000000 +0200
62
 
+++ curl/docs/examples/Makefile.am      2008-06-04 19:03:05.000000000 +0200
63
 
@@ -19,7 +19,7 @@
 
61
--- curl.orig/docs/examples/Makefile.am 2009-04-03 10:20:11.000000000 +0200
 
62
+++ curl/docs/examples/Makefile.am      2009-04-03 10:32:03.000000000 +0200
 
63
@@ -28,7 +28,7 @@
64
64
 CPPFLAGS = -DCURL_NO_OLDIES $(STATICCPPFLAGS)
65
65
 
66
66
 # Dependencies
69
69
 
70
70
 # Makefile.inc provides the check_PROGRAMS and COMPLICATED_EXAMPLES defines
71
71
 include Makefile.inc
 
72
Index: curl/configure.ac
 
73
===================================================================
 
74
--- curl.orig/configure.ac      2009-04-03 10:32:23.000000000 +0200
 
75
+++ curl/configure.ac   2009-04-03 10:37:33.000000000 +0200
 
76
@@ -1593,7 +1593,7 @@
 
77
       CLEANCPPFLAGS="$CPPFLAGS"
 
78
       CLEADLDFLAGS="$LDFLAGS"
 
79
 
 
80
-      LIBS="$LIBS $addlib"
 
81
+      LIBS="$LIBS $addlib -lgcrypt"
 
82
       LDFLAGS="$LDFLAGS $addld"
 
83
       if test "$addcflags" != "-I/usr/include"; then
 
84
          CPPFLAGS="$CPPFLAGS $addcflags"