~ubuntu-branches/ubuntu/vivid/deal.ii/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/srcdir.patch

  • Committer: Bazaar Package Importer
  • Author(s): Adam C. Powell, IV
  • Date: 2009-05-08 23:13:50 UTC
  • Revision ID: james.westby@ubuntu.com-20090508231350-y2bnbq7napm1eltt
Tags: 6.2.0-2
* Added Trilinos linkage.
* Changed compilers to mpicc and mpicxx to make trilinos tests work.
* Fixed library variables using a sed hack.
* Added PIC flag to soname test.
* Fixed a couple of other lintian warnings.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Change $(D) to point to installed location instead of build.
 
2
 
 
3
--- deal.ii-6.1.0/common/Make.global_options.in~        2008-03-04 21:08:20.000000000 +0000
 
4
+++ deal.ii-6.1.0/common/Make.global_options.in 2008-08-11 22:22:21.000000000 +0000
 
5
@@ -21,7 +21,7 @@
 
6
 # the following lines will be replaced by the output 
 
7
 # of ./configure
 
8
 
 
9
-D                    = @prefix@
 
10
+D                    = @DEAL_II_PATH@
 
11
 CXX                  = @CXX@
 
12
 GXX-VERSION          = @GXX_VERSION@
 
13
 GXX-VERSION-DETAILED = @GXX_VERSION_DETAILED@
 
14
--- deal.ii-6.1.0/doc/Makefile.in~      2006-07-24 11:20:09.000000000 -0400
 
15
+++ deal.ii-6.1.0/doc/Makefile.in       2008-08-27 06:42:18.000000000 -0400
 
16
@@ -3,7 +3,7 @@
 
17
 ###############################
 
18
 # Configured variables
 
19
 
 
20
-D     = @prefix@
 
21
+D     = @DEAL_II_PATH@
 
22
 include $D/common/Make.global_options
 
23
 
 
24
 
 
25
--- deal.ii-6.1.0/doc/doxygen/Makefile.in~      2007-08-21 12:24:27.000000000 -0400
 
26
+++ deal.ii-6.1.0/doc/doxygen/Makefile.in       2008-08-27 06:44:16.000000000 -0400
 
27
@@ -6,7 +6,7 @@
 
28
 ###############################
 
29
 # Configured variables
 
30
 
 
31
-D     = @prefix@
 
32
+D     = @DEAL_II_PATH@
 
33
 include $D/common/Make.global_options
 
34
 
 
35
 
 
36
--- deal.ii-6.1.0/doc/doxygen/options.dox.in~   2008-01-15 19:48:26.000000000 -0500
 
37
+++ deal.ii-6.1.0/doc/doxygen/options.dox.in    2008-08-27 06:45:42.000000000 -0400
 
38
@@ -105,7 +105,7 @@
 
39
 # If left blank the directory from which doxygen is run is used as the 
 
40
 # path to strip.
 
41
 
 
42
-STRIP_FROM_PATH        = @prefix@
 
43
+STRIP_FROM_PATH        = @DEAL_II_PATH@
 
44
 
 
45
 # The STRIP_FROM_INC_PATH tag can be used to strip a user-defined part of 
 
46
 # the path mentioned in the documentation of a class, which tells 
 
47
@@ -483,7 +483,7 @@
 
48
 # directories that contain example code fragments that are included (see 
 
49
 # the \include command).
 
50
 
 
51
-EXAMPLE_PATH           = @prefix@/examples/doxygen
 
52
+EXAMPLE_PATH           = @DEAL_II_PATH@/examples/doxygen
 
53
 
 
54
 # If the value of the EXAMPLE_PATH tag contains directories, you can use the 
 
55
 # EXAMPLE_PATTERNS tag to specify one or more wildcard pattern (like *.cpp 
 
56
@@ -980,9 +980,9 @@
 
57
 # contain include files that are not input files but should be processed by 
 
58
 # the preprocessor.
 
59
 
 
60
-INCLUDE_PATH           = @prefix@/base/include \
 
61
-                        @prefix@/lac/include \
 
62
-                        @prefix@/deal.II/include
 
63
+INCLUDE_PATH           = @DEAL_II_PATH@/base/include \
 
64
+                        @DEAL_II_PATH@/lac/include \
 
65
+                        @DEAL_II_PATH@/deal.II/include
 
66
 
 
67
 # You can use the INCLUDE_FILE_PATTERNS tag to specify one or more wildcard 
 
68
 # patterns (like *.h and *.hpp) to filter out the header-files in the