~ubuntu-branches/ubuntu/vivid/exuberant-ctags/vivid

« back to all changes in this revision

Viewing changes to debian/patches/vim-command-loop.patch

  • Committer: Package Import Robot
  • Author(s): Colin Watson
  • Date: 2014-02-15 23:52:23 UTC
  • Revision ID: package-import@ubuntu.com-20140215235223-mxhk4b95fi9rlfrw
Tags: 1:5.9~svn20110310-7
* Add a Homepage field.
* Switch to git; add Vcs-* fields.
* Add a hacky "debian/rules git-svn-setup", making it possible to set up
  git-svn metadata again after cloning.
* Policy version 3.9.5: no changes required.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix infinite loop parsing vim commands
2
 
 This happens if a non-alphanumeric character other than whitespace or '-'
3
 
 is found before the first alphanumeric character after 'command'.
4
 
Author: Colin Watson <cjwatson@ubuntu.com>
 
1
From 15b3c591abd3b0e4334f9fba19a9b75330b33c26 Mon Sep 17 00:00:00 2001
 
2
From: Colin Watson <cjwatson@ubuntu.com>
 
3
Date: Sat, 15 Feb 2014 22:47:02 +0000
 
4
Subject: Fix infinite loop parsing vim commands
 
5
 
 
6
This happens if a non-alphanumeric character other than whitespace or '-' is
 
7
found before the first alphanumeric character after 'command'.
 
8
 
5
9
Bug: http://sourceforge.net/tracker/index.php?func=detail&aid=3214129&group_id=6556&atid=106556
6
10
Bug-Ubuntu: https://bugs.launchpad.net/bugs/736367
7
11
Forwarded: no
8
12
Last-Update: 2011-03-17
9
13
 
10
 
Index: b/vim.c
11
 
===================================================================
 
14
Patch-Name: vim-command-loop.patch
 
15
---
 
16
 vim.c | 4 +++-
 
17
 1 file changed, 3 insertions(+), 1 deletion(-)
 
18
 
 
19
diff --git a/vim.c b/vim.c
 
20
index 4e6fba8..d17a1ba 100644
12
21
--- a/vim.c
13
22
+++ b/vim.c
14
 
@@ -405,7 +405,9 @@
 
23
@@ -405,7 +405,9 @@ static boolean parseCommand (const unsigned char *line)
15
24
                        while (*cp && !isspace ((int) *cp))
16
25
                                ++cp; 
17
26
                }