~ubuntu-branches/ubuntu/vivid/ffmpeg/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/stop-embedding-the-build-date.patch

  • Committer: Package Import Robot
  • Author(s): Andreas Cadhalpun
  • Date: 2015-02-14 23:14:52 UTC
  • mfrom: (0.1.22)
  • Revision ID: package-import@ubuntu.com-20150214231452-od0roffwuk2030e1
Tags: 7:2.5.4-1
* Import new upstream bugfix release 2.5.4.
* Drop configure-enable-vsx-together-with-altivec-for-ppc64el.patch
  included upstream.
* Add patches making the build binary reproducible.
* Stop using faketime.
* Correctly handle noopt in DEB_BUILD_OPTIONS.
* Disable assembler optimizations on ppc64el, as they don't work yet.
* Disable assembler optimizations on mips64(el), as they don't work yet.
  Thanks to James Cowgill. (Closes: #776649)
* Fix dep5-copyright-license-name-not-unique lintian warnings.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 103e4c58633f210d7c3203cae121ba5b5123afa6 Mon Sep 17 00:00:00 2001
 
2
From: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
 
3
Date: Mon, 2 Feb 2015 00:20:18 +0100
 
4
Subject: [PATCH] stop embedding the build date
 
5
 
 
6
Theis makes the build binary reproducible.
 
7
 
 
8
Signed-off-by: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
 
9
Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
 
10
---
 
11
 cmdutils.c          |  3 +--
 
12
 doc/Makefile        |  4 ++--
 
13
 doc/doxy-wrapper.sh |  1 +
 
14
 doc/t2h.pm          | 17 +++++++++++++++++
 
15
 ffprobe.c           |  2 --
 
16
 5 files changed, 21 insertions(+), 6 deletions(-)
 
17
 
 
18
diff --git a/cmdutils.c b/cmdutils.c
 
19
index 53268d8..6c40df9 100644
 
20
--- a/cmdutils.c
 
21
+++ b/cmdutils.c
 
22
@@ -1081,8 +1081,7 @@ static void print_program_info(int flags, int level)
 
23
         av_log(NULL, level, " Copyright (c) %d-%d the FFmpeg developers",
 
24
                program_birth_year, CONFIG_THIS_YEAR);
 
25
     av_log(NULL, level, "\n");
 
26
-    av_log(NULL, level, "%sbuilt on %s %s with %s\n",
 
27
-           indent, __DATE__, __TIME__, CC_IDENT);
 
28
+    av_log(NULL, level, "%sbuilt with %s\n", indent, CC_IDENT);
 
29
 
 
30
     av_log(NULL, level, "%sconfiguration: " FFMPEG_CONFIGURATION "\n", indent);
 
31
 }
 
32
diff --git a/doc/Makefile b/doc/Makefile
 
33
index 2502922..745576c 100644
 
34
--- a/doc/Makefile
 
35
+++ b/doc/Makefile
 
36
@@ -114,9 +114,9 @@ doc/%-all.pod: doc/%.texi $(SRC_PATH)/doc/texi2pod.pl $(GENTEXI)
 
37
 
 
38
 doc/%.1 doc/%.3: TAG = MAN
 
39
 doc/%.1: doc/%.pod $(GENTEXI)
 
40
-       $(M)pod2man --section=1 --center=" " --release=" " $< > $@
 
41
+       $(M)pod2man --section=1 --center=" " --release=" " --date=" " $< > $@
 
42
 doc/%.3: doc/%.pod $(GENTEXI)
 
43
-       $(M)pod2man --section=3 --center=" " --release=" " $< > $@
 
44
+       $(M)pod2man --section=3 --center=" " --release=" " --date=" " $< > $@
 
45
 
 
46
 $(DOCS) doc/doxy/html: | doc/
 
47
 $(DOC_EXAMPLES:%$(EXESUF)=%.o): | doc/examples
 
48
diff --git a/doc/doxy-wrapper.sh b/doc/doxy-wrapper.sh
 
49
index d88f60e..bbdb909 100755
 
50
--- a/doc/doxy-wrapper.sh
 
51
+++ b/doc/doxy-wrapper.sh
 
52
@@ -10,4 +10,5 @@ $DOXYGEN - <<EOF
 
53
 @INCLUDE        = ${DOXYFILE}
 
54
 INPUT           = $@
 
55
 EXAMPLE_PATH    = ${SRC_PATH}/doc/examples
 
56
+HTML_TIMESTAMP  = NO
 
57
 EOF
 
58
diff --git a/doc/t2h.pm b/doc/t2h.pm
 
59
index ca77842..5efb2da 100644
 
60
--- a/doc/t2h.pm
 
61
+++ b/doc/t2h.pm
 
62
@@ -186,6 +186,23 @@ EOT
 
63
 }
 
64
 texinfo_register_formatting_function('begin_file', \&ffmpeg_begin_file);
 
65
 
 
66
+sub ffmpeg_program_string($)
 
67
+{
 
68
+  my $self = shift;
 
69
+  if (defined($self->get_conf('PROGRAM'))
 
70
+      and $self->get_conf('PROGRAM') ne ''
 
71
+      and defined($self->get_conf('PACKAGE_URL'))) {
 
72
+    return $self->convert_tree(
 
73
+      $self->gdt('This document was generated using @uref{{program_homepage}, @emph{{program}}}.',
 
74
+         { 'program_homepage' => $self->get_conf('PACKAGE_URL'),
 
75
+           'program' => $self->get_conf('PROGRAM') }));
 
76
+  } else {
 
77
+    return $self->convert_tree(
 
78
+      $self->gdt('This document was generated automatically.'));
 
79
+  }
 
80
+}
 
81
+texinfo_register_formatting_function('program_string', \&ffmpeg_program_string);
 
82
+
 
83
 # Customized file ending
 
84
 sub ffmpeg_end_file($)
 
85
 {
 
86
diff --git a/ffprobe.c b/ffprobe.c
 
87
index 38879f1..d352bb6 100644
 
88
--- a/ffprobe.c
 
89
+++ b/ffprobe.c
 
90
@@ -2562,8 +2562,6 @@ static void ffprobe_show_program_version(WriterContext *w)
 
91
     print_str("version", FFMPEG_VERSION);
 
92
     print_fmt("copyright", "Copyright (c) %d-%d the FFmpeg developers",
 
93
               program_birth_year, CONFIG_THIS_YEAR);
 
94
-    print_str("build_date", __DATE__);
 
95
-    print_str("build_time", __TIME__);
 
96
     print_str("compiler_ident", CC_IDENT);
 
97
     print_str("configuration", FFMPEG_CONFIGURATION);
 
98
     writer_print_section_footer(w);
 
99
-- 
 
100
2.1.4
 
101