~ubuntu-branches/ubuntu/vivid/flwm/vivid

« back to all changes in this revision

Viewing changes to debian/patches/06-create-dirs.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Patrick Matthäi
  • Date: 2008-10-14 20:33:47 UTC
  • Revision ID: james.westby@ubuntu.com-20081014203347-e8rw5j30mq223f0j
Tags: 1.02+cvs20080422-4
Uploading to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh /usr/share/dpatch/dpatch-run
 
2
## 06-create-dirs.dpatch by Patrick Matthäi <patrick.matthaei@web.de>
 
3
##
 
4
## DP: Let install also create the directorys if they are missing.
 
5
 
 
6
@DPATCH@
 
7
 
 
8
diff -Naur flwm-1.02+cvs20080422.orig/Makefile flwm-1.02+cvs20080422/Makefile
 
9
--- flwm-1.02+cvs20080422.orig/Makefile 2008-09-06 11:21:27.000000000 +0200
 
10
+++ flwm-1.02+cvs20080422/Makefile      2008-09-06 11:21:59.000000000 +0200
 
11
@@ -42,8 +42,8 @@
 
12
 include makedepend
 
13
 
 
14
 install: $(PROGRAM)
 
15
-       $(INSTALL) $(PROGRAM) $(bindir)/$(PROGRAM)
 
16
-       $(INSTALL) $(PROGRAM).$(MANPAGE) $(mandir)/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
 
17
+       $(INSTALL) -D $(PROGRAM) $(bindir)/$(PROGRAM)
 
18
+       $(INSTALL) -D $(PROGRAM).$(MANPAGE) $(mandir)/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
 
19
 
 
20
 uninstall:
 
21
        -@ rm -f $(bindir)/$(PROGRAM)