~ubuntu-branches/ubuntu/vivid/freerdp/vivid

« back to all changes in this revision

Viewing changes to debian/patches/1008_gcc-fPIC-on-arm64.patch

  • Committer: Package Import Robot
  • Author(s): Iain Lane
  • Date: 2014-11-11 12:20:50 UTC
  • mfrom: (1.1.9) (9.1.17 sid)
  • Revision ID: package-import@ubuntu.com-20141111122050-wyr8hrnwco9fcmum
Tags: 1.1.0~git20140921.1.440916e+dfsg1-2ubuntu1
* Merge with Debian unstable, remaining changes
  - Disable ffmpeg support
* Disable gstreamer support, this relies on gstreamer 0.10 and we don't want
  to add any more deps on that.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: CPU types arm64 and armhf need to be linked with -fPIC.
 
2
Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
 
3
 
 
4
--- a/CMakeLists.txt
 
5
+++ b/CMakeLists.txt
 
6
@@ -118,6 +118,9 @@
 
7
                        set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=i686")
 
8
                endif()
 
9
        endif()
 
10
+       if (CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l" OR CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
 
11
+               set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
 
12
+       endif()
 
13
        set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
 
14
        CHECK_C_COMPILER_FLAG (-Wno-unused-result Wno-unused-result)
 
15
        if(Wno-unused-result)