~ubuntu-branches/ubuntu/vivid/keepalived/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_libnl3.patch

  • Committer: Daniel Holbach
  • Date: 2011-12-23 14:50:21 UTC
  • mfrom: (16.1.3 keepalived)
  • Revision ID: daniel.holbach@canonical.com-20111223145021-vwaoakdgtv8ns2jq
Tags: 1:1.2.2-3ubuntu1
* Merge with Debian unstable. Remaining changes:
  - debian/rules: DEB_UPDATE_RCD_PARAMS := explicit init start/stop
    parameters (don't stop at 0 and 6)
  - debian/init.d: init script header adapted to stop rule
  - debian/keepalived.postinst: Remove shutdown and reboot links
  - Build with libnl3, thanks to a patch from Marc - A. Dahlhaus.
* debian/control: in Build-Depends: libnl3-dev -> libnl-3-dev,
  libnl-genl-3-dev.
* debian/patches/ubuntu_libnl3.patch: update patch, make sure it works for
  libnl3 3.2.x.
* [c28d5f0] Readd ip_vs.h - this reenables ipvs (Closes: #649778)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: Support libnl version 2.0 and higher
2
2
Author: Marc - A. Dahlhaus <mad@wol.de>
3
3
Forwarded: http://article.gmane.org/gmane.linux.keepalived.devel/3522
4
 
Last-Update: 2011-10-25
 
4
Last-Update: 2011-12-21
5
5
 
6
 
diff -Nur -x '*.orig' -x '*~' keepalived-1.2.2//configure keepalived-1.2.2.new//configure
7
 
--- keepalived-1.2.2//configure 2011-10-25 15:53:17.000000000 +0100
8
 
+++ keepalived-1.2.2.new//configure     2011-10-25 16:05:16.000000000 +0100
9
 
@@ -3903,13 +3903,59 @@
 
6
diff -Nur -x '*.orig' -x '*~' keepalived/configure keepalived.new/configure
 
7
--- keepalived/configure        2011-12-15 22:11:52.353950000 -0500
 
8
+++ keepalived.new/configure    2011-12-21 16:25:40.069869704 -0500
 
9
@@ -3884,13 +3884,59 @@
10
10
     LIBS="$LIBS -lnl"
11
11
 
12
12
 else
50
50
+
51
51
+      USE_NL="LIBIPVS_USE_NL"
52
52
+      CFLAGS="$CFLAGS -DLIBNL2"
53
 
+      LIBS="$LIBS -lnl -lnl-genl"
 
53
+      LIBS="$LIBS -lnl-3 -lnl-genl-3"
54
54
 
55
55
-    USE_NL="LIBIPVS_DONTUSE_NL"
56
56
-    { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: keepalived will be built without libnl support." >&5
68
68
 
69
69
 CPPFLAGS="$CPPFLAGS -I$kernelinc"
70
70
 { $as_echo "$as_me:${as_lineno-$LINENO}: checking for kernel version" >&5
71
 
diff -Nur -x '*.orig' -x '*~' keepalived-1.2.2//configure.in keepalived-1.2.2.new//configure.in
72
 
--- keepalived-1.2.2//configure.in      2011-10-25 15:59:54.000000000 +0100
73
 
+++ keepalived-1.2.2.new//configure.in  2011-10-25 16:05:14.000000000 +0100
 
71
diff -Nur -x '*.orig' -x '*~' keepalived/configure.in keepalived.new/configure.in
 
72
--- keepalived/configure.in     2011-12-15 22:11:52.353950000 -0500
 
73
+++ keepalived.new/configure.in 2011-12-21 16:27:10.041874926 -0500
74
74
@@ -56,9 +56,16 @@
75
75
     USE_NL="LIBIPVS_USE_NL"
76
76
     LIBS="$LIBS -lnl"
78
78
-  [
79
79
-    USE_NL="LIBIPVS_DONTUSE_NL"
80
80
-    AC_MSG_WARN([keepalived will be built without libnl support.])
81
 
+  [AC_CHECK_LIB(nl, nl_socket_alloc,
 
81
+  [AC_CHECK_LIB(nl-3, nl_socket_alloc,
82
82
+    [
83
83
+      USE_NL="LIBIPVS_USE_NL"
84
 
+      CFLAGS="$CFLAGS -DLIBNL2"
85
 
+      LIBS="$LIBS -lnl -lnl-genl"
 
84
+      CFLAGS="$CFLAGS -I/usr/include/libnl3 -DLIBNL2"
 
85
+      LIBS="$LIBS -lnl-3 -lnl-genl-3"
86
86
+    ],
87
87
+    [
88
88
+      USE_NL="LIBIPVS_DONTUSE_NL"
91
91
   ])
92
92
 
93
93
 dnl ----[ Kernel version check ]----
94
 
diff -Nur -x '*.orig' -x '*~' keepalived-1.2.2//keepalived/libipvs-2.6/libipvs.c keepalived-1.2.2.new//keepalived/libipvs-2.6/libipvs.c
95
 
--- keepalived-1.2.2//keepalived/libipvs-2.6/libipvs.c  2011-05-29 11:19:59.000000000 +0100
96
 
+++ keepalived-1.2.2.new//keepalived/libipvs-2.6/libipvs.c      2011-10-25 16:06:07.000000000 +0100
 
94
diff -Nur -x '*.orig' -x '*~' keepalived/keepalived/libipvs-2.6/libipvs.c keepalived.new/keepalived/libipvs-2.6/libipvs.c
 
95
--- keepalived/keepalived/libipvs-2.6/libipvs.c 2011-12-15 22:11:52.353950000 -0500
 
96
+++ keepalived.new/keepalived/libipvs-2.6/libipvs.c     2011-12-21 16:25:40.073869704 -0500
97
97
@@ -34,6 +34,11 @@
98
98
 struct ip_vs_getinfo ipvs_info;
99
99