~ubuntu-branches/ubuntu/vivid/libclass-meta-perl/vivid

« back to all changes in this revision

Viewing changes to debian/patches/spelling.patch

  • Committer: Bazaar Package Importer
  • Author(s): Peter Pentchev, Nathan Handler, gregor herrmann, Peter Pentchev
  • Date: 2011-02-25 01:56:19 UTC
  • mfrom: (3.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20110225015619-tf7yn3satbkbs3r3
Tags: 0.63-2
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.

[ gregor herrmann ]
* debian/control: Changed: (build-)depend on perl instead of perl-
  modules.
* Drop build dependency on "perl (>= 5.10) | libmodule-build-perl", already
  satisfied in lenny.

[ Peter Pentchev ]
* Convert to the 3.0 (quilt) source format with no changes.
* Depend on libclass-isa-perl | perl (<< 5.10.1-13).  Closes: #614410
* Refresh the copyright file:
  - refer to the GPL-1 file instead of the GPL symlink
  - update it to the latest DEP 5 candidate format
  - refer to Debian (not just GNU/Linux) systems
  - add my debian/* copyright notice
* Bump Standards-Version to 3.9.1 with no changes.
* Add spelling.patch to fix two spelling mistakes and a grammatical one.
* Bump the debhelper compatibility level to 8 with no changes and
  minimize the rules file.
* Drop the 5.8.0-7 version from the perl build dependency.
* Add myself to the list of uploaders.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix two spelling mistakes and a grammatical one.
 
2
Forwarded: no
 
3
Author: Peter Pentchev <roam@ringlet.net>
 
4
Last-Update: 2011-02-24
 
5
 
 
6
--- a/lib/Class/Meta.pm
 
7
+++ b/lib/Class/Meta.pm
 
8
@@ -69,9 +69,9 @@
 
9
       has  uuid => (
 
10
         authz    => 'READ',
 
11
         required => 1,
 
12
-        deafult  => sub { Data::UUID->new->create_str },
 
13
+        default  => sub { Data::UUID->new->create_str },
 
14
       );
 
15
-      has name => ( rquired => 1         );
 
16
+      has name => ( required => 1         );
 
17
       has age  => ( is      => 'integer' );
 
18
       method chk_pass => sub { ... }
 
19
   };
 
20
@@ -143,7 +143,7 @@
 
21
 Class::Meta interface itself, well, read on!
 
22
 
 
23
 I recommend that you create your Class::Meta classes in a C<BEGIN> block.
 
24
-Although this is not strictly necessary, it helps to ensure that the classes
 
25
+Although this is not strictly necessary, it helps ensure that the classes
 
26
 you're building are completely constructed and ready to go by the time
 
27
 compilation has completed. Creating classes with Class::Meta is easy, using
 
28
 the Class::Meta object oriented interface. Here is an example of a very simple