~ubuntu-branches/ubuntu/vivid/libjpeg6b/vivid

« back to all changes in this revision

Viewing changes to debian/patches/300_config.sub.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Bill Allombert
  • Date: 2010-06-29 13:55:42 UTC
  • mfrom: (4.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20100629135542-u2ux634ovmawtrog
Tags: 6b1-1
* New upstream release
  - libjpeg62 has now versionned symbols.
  - Updated build system that use current libtool.
  - Full source code for the build system.
* debian/copyright: add 6b1 upstream download URL.
* debian/control:
  - libjpeg62-dev: Provides libjpeg-dev since the transition has been
    postponed.
  - Remove now useless dependency on libtool and sharutils
  - Bump Standards-Version to 3.9.0.
* Get rid of dpatch system. Patches were only relevant to libjpeg-progs
  which is not build from this package anymore.
* Move to new source format 3.0 (quilt). Patches applied:
  - use-autotools-dev: Use autotools-dev version of config.sub/.guess.
  - extern_C-jpeglib.h: Wrap jpeglib.h with extern "C" {} if __cplusplus 
    is defined.
* debian/rules:
  - Adjust for new build system and new patch system.
* debian/shlibs: add (>=6b1) to avoid linker warnings with libjpeg6b.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
# DP: Fix config.{sub,guess} to use autotools-dev version.
4
 
 
5
 
case "$1" in
6
 
    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
7
 
    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
8
 
    *)
9
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
10
 
        exit 1
11
 
esac
12
 
exit 0
13
 
@DPATCH@
14
 
--- jpeg-6b/config.guess        Wed Mar 25 16:25:38 1998
15
 
+++ libjpeg6b-6b/config.guess   Wed Feb 26 01:04:42 2003
16
 
@@ -1,4 +1,10 @@
17
 
 #! /bin/sh
18
 
+# autotools-dev hack (<ballombe@debian.org>, Wed, 14 Nov 2001 10:13:10 +0100)
19
 
+if [ -x /usr/share/misc/config.guess ]; then
20
 
+   /usr/share/misc/config.guess $*
21
 
+   exit $?
22
 
+fi
23
 
+
24
 
 # Attempt to guess a canonical system name.
25
 
 #   Copyright (C) 1992, 93, 94, 95, 96, 1997 Free Software Foundation, Inc.
26
 
 #
27
 
--- jpeg-6b/config.sub  Wed Mar 25 16:25:39 1998
28
 
+++ libjpeg6b-6b/config.sub     Wed Feb 26 01:04:42 2003
29
 
@@ -1,4 +1,10 @@
30
 
 #! /bin/sh
31
 
+# autotools-dev hack (<ballombe@debian.org>, Wed, 14 Nov 2001 10:13:10 +0100)
32
 
+if [ -x /usr/share/misc/config.sub ]; then
33
 
+   /usr/share/misc/config.sub $*
34
 
+   exit $?
35
 
+fi
36
 
+
37
 
 # Configuration validation subroutine script, version 1.1.
38
 
 #   Copyright (C) 1991, 92, 93, 94, 95, 96, 1997 Free Software Foundation, Inc.
39
 
 # This file is (in principle) common to ALL GNU software.