~ubuntu-branches/ubuntu/vivid/librest/vivid

« back to all changes in this revision

Viewing changes to debian/patches/02_g_thread_init_deprecation.patch

  • Committer: Package Import Robot
  • Author(s): Ying-Chun Liu (PaulLiu), Ying-Chun Liu (PaulLiu), Martin Pitt, Adam Conrad
  • Date: 2012-05-27 21:46:10 UTC
  • mfrom: (3.1.7 sid)
  • Revision ID: package-import@ubuntu.com-20120527214610-opmtp67l3uh6th2j
Tags: 0.7.12-2
[ Ying-Chun Liu (PaulLiu) <paulliu@debian.org> ]
* Update debian/copyright to latest format
* Bump Standards-Version to 3.9.3: nothing needs to be changed
* Multi-arch support.
  - Bump debhelper compat to 9

[ Martin Pitt <martin.pitt@ubuntu.com> ]
* Add g_thread_init_deprecation.patch: Fix FTBFS with current glib due to
  deprecation of g_init_threads(). (LP: #911125)

[ Adam Conrad <adconrad@ubuntu.com> ]
* debian/patches/01_disable-network-tests.patch: disable the tests
  in the testsuite that require access outside our buildd network
  (Closes: #674374)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 6f4e66f87ccf10d8dff6b764ece0ad33b2191b63 Mon Sep 17 00:00:00 2001
 
2
From: Martin Pitt <martin.pitt@ubuntu.com>
 
3
Date: Tue, 3 Jan 2012 14:59:08 +0100
 
4
Subject: [PATCH] Drop obsolete g_thread_init()
 
5
 
 
6
Since version 2.2 g_type_init() initializes also the thread
 
7
system so g_thread_init() is not required anymore. It is deprecated since glib
 
8
2.31.
 
9
 
 
10
Bump glib requirement accordingly.
 
11
 
 
12
https://bugzilla.gnome.org/show_bug.cgi?id=650061
 
13
---
 
14
 configure.ac                      |    2 +-
 
15
 examples/continuous-twitter.c     |    1 -
 
16
 examples/get-fireeagle-location.c |    1 -
 
17
 examples/get-flickr-favorites.c   |    1 -
 
18
 examples/lastfm-shout.c           |    1 -
 
19
 examples/post-twitter.c           |    1 -
 
20
 examples/test-raw.c               |    1 -
 
21
 examples/test-xml.c               |    1 -
 
22
 tests/custom-serialize.c          |    1 -
 
23
 tests/flickr.c                    |    1 -
 
24
 tests/lastfm.c                    |    1 -
 
25
 tests/oauth-async.c               |    1 -
 
26
 tests/oauth.c                     |    1 -
 
27
 tests/oauth2.c                    |    1 -
 
28
 tests/proxy-continuous.c          |    1 -
 
29
 tests/proxy.c                     |    1 -
 
30
 tests/threaded.c                  |    1 -
 
31
 tests/xml.c                       |    1 -
 
32
 18 files changed, 1 insertions(+), 18 deletions(-)
 
33
 
 
34
Index: librest-0.7.12/examples/continuous-twitter.c
 
35
===================================================================
 
36
--- librest-0.7.12.orig/examples/continuous-twitter.c   2012-05-27 21:38:06.167613589 +0800
 
37
+++ librest-0.7.12/examples/continuous-twitter.c        2012-05-27 21:38:16.607431425 +0800
 
38
@@ -43,7 +43,6 @@
 
39
   char pin[256];
 
40
   GMainLoop *loop;
 
41
 
 
42
-  g_thread_init (NULL);
 
43
   g_type_init ();
 
44
 
 
45
   loop = g_main_loop_new (NULL, FALSE);
 
46
Index: librest-0.7.12/examples/get-fireeagle-location.c
 
47
===================================================================
 
48
--- librest-0.7.12.orig/examples/get-fireeagle-location.c       2012-05-27 21:38:06.167613589 +0800
 
49
+++ librest-0.7.12/examples/get-fireeagle-location.c    2012-05-27 21:38:16.607431425 +0800
 
50
@@ -34,7 +34,6 @@
 
51
   RestXmlParser *parser;
 
52
   RestXmlNode *root, *node;
 
53
 
 
54
-  g_thread_init (NULL);
 
55
   g_type_init ();
 
56
 
 
57
   /* Create the proxy */
 
58
Index: librest-0.7.12/examples/get-flickr-favorites.c
 
59
===================================================================
 
60
--- librest-0.7.12.orig/examples/get-flickr-favorites.c 2012-05-27 21:38:06.167613589 +0800
 
61
+++ librest-0.7.12/examples/get-flickr-favorites.c      2012-05-27 21:38:16.611431356 +0800
 
62
@@ -106,7 +106,6 @@
 
63
   char *frob, *url;
 
64
   const char *token;
 
65
 
 
66
-  g_thread_init (NULL);
 
67
   g_type_init ();
 
68
 
 
69
   proxy = flickr_proxy_new ("cf4e02fc57240a9b07346ad26e291080", "cdfa2329cb206e50");
 
70
Index: librest-0.7.12/examples/lastfm-shout.c
 
71
===================================================================
 
72
--- librest-0.7.12.orig/examples/lastfm-shout.c 2012-05-27 21:38:06.167613589 +0800
 
73
+++ librest-0.7.12/examples/lastfm-shout.c      2012-05-27 21:38:16.611431356 +0800
 
74
@@ -87,7 +87,6 @@
 
75
     { NULL }
 
76
   };
 
77
 
 
78
-  g_thread_init (NULL);
 
79
   g_type_init ();
 
80
 
 
81
   context = g_option_context_new ("- send a shout to a Last.fm user");
 
82
Index: librest-0.7.12/examples/post-twitter.c
 
83
===================================================================
 
84
--- librest-0.7.12.orig/examples/post-twitter.c 2012-05-27 21:38:06.167613589 +0800
 
85
+++ librest-0.7.12/examples/post-twitter.c      2012-05-27 21:38:16.611431356 +0800
 
86
@@ -31,7 +31,6 @@
 
87
   GError *error = NULL;
 
88
   char pin[256];
 
89
 
 
90
-  g_thread_init (NULL);
 
91
   g_type_init ();
 
92
 
 
93
   if (argc != 2) {
 
94
Index: librest-0.7.12/examples/test-raw.c
 
95
===================================================================
 
96
--- librest-0.7.12.orig/examples/test-raw.c     2012-05-27 21:38:06.167613589 +0800
 
97
+++ librest-0.7.12/examples/test-raw.c  2012-05-27 21:38:16.611431356 +0800
 
98
@@ -48,7 +48,6 @@
 
99
   gssize len;
 
100
 
 
101
   g_type_init ();
 
102
-  g_thread_init (NULL);
 
103
 
 
104
   loop = g_main_loop_new (NULL, FALSE);
 
105
 
 
106
Index: librest-0.7.12/examples/test-xml.c
 
107
===================================================================
 
108
--- librest-0.7.12.orig/examples/test-xml.c     2012-05-27 21:38:06.167613589 +0800
 
109
+++ librest-0.7.12/examples/test-xml.c  2012-05-27 21:38:16.611431356 +0800
 
110
@@ -114,7 +114,6 @@
 
111
   GMainLoop *loop;
 
112
 
 
113
   g_type_init ();
 
114
-  g_thread_init (NULL);
 
115
 
 
116
   loop = g_main_loop_new (NULL, FALSE);
 
117
 
 
118
Index: librest-0.7.12/tests/custom-serialize.c
 
119
===================================================================
 
120
--- librest-0.7.12.orig/tests/custom-serialize.c        2012-05-27 21:38:06.167613589 +0800
 
121
+++ librest-0.7.12/tests/custom-serialize.c     2012-05-27 21:38:16.611431356 +0800
 
122
@@ -124,7 +124,6 @@
 
123
   int i;
 
124
   GError *error;
 
125
 
 
126
-  g_thread_init (NULL);
 
127
   g_type_init ();
 
128
 
 
129
   session = soup_session_sync_new ();
 
130
Index: librest-0.7.12/tests/flickr.c
 
131
===================================================================
 
132
--- librest-0.7.12.orig/tests/flickr.c  2012-05-27 21:38:06.167613589 +0800
 
133
+++ librest-0.7.12/tests/flickr.c       2012-05-27 21:38:16.611431356 +0800
 
134
@@ -36,7 +36,6 @@
 
135
   RestXmlParser *parser;
 
136
   RestXmlNode *root, *node;
 
137
 
 
138
-  g_thread_init (NULL);
 
139
   g_type_init ();
 
140
 
 
141
   /* Create the proxy */
 
142
Index: librest-0.7.12/tests/lastfm.c
 
143
===================================================================
 
144
--- librest-0.7.12.orig/tests/lastfm.c  2012-05-27 21:38:06.167613589 +0800
 
145
+++ librest-0.7.12/tests/lastfm.c       2012-05-27 21:38:16.611431356 +0800
 
146
@@ -37,7 +37,6 @@
 
147
   RestXmlParser *parser;
 
148
   RestXmlNode *root, *u_node, *node;
 
149
 
 
150
-  g_thread_init (NULL);
 
151
   g_type_init ();
 
152
 
 
153
   /* Create the proxy */
 
154
Index: librest-0.7.12/tests/oauth-async.c
 
155
===================================================================
 
156
--- librest-0.7.12.orig/tests/oauth-async.c     2012-05-27 21:38:06.167613589 +0800
 
157
+++ librest-0.7.12/tests/oauth-async.c  2012-05-27 21:38:16.611431356 +0800
 
158
@@ -113,7 +113,6 @@
 
159
   OAuthProxy *oproxy;
 
160
   GError *error = NULL;
 
161
 
 
162
-  g_thread_init (NULL);
 
163
   g_type_init ();
 
164
 
 
165
   /* Install a timeout so that we don't hang or infinite loop */
 
166
Index: librest-0.7.12/tests/oauth.c
 
167
===================================================================
 
168
--- librest-0.7.12.orig/tests/oauth.c   2012-05-27 21:38:06.167613589 +0800
 
169
+++ librest-0.7.12/tests/oauth.c        2012-05-27 21:38:16.611431356 +0800
 
170
@@ -33,7 +33,6 @@
 
171
   RestProxyCall *call;
 
172
   GError *error = NULL;
 
173
 
 
174
-  g_thread_init (NULL);
 
175
   g_type_init ();
 
176
 
 
177
   /* Create the proxy */
 
178
Index: librest-0.7.12/tests/oauth2.c
 
179
===================================================================
 
180
--- librest-0.7.12.orig/tests/oauth2.c  2012-05-27 21:38:06.167613589 +0800
 
181
+++ librest-0.7.12/tests/oauth2.c       2012-05-27 21:38:16.611431356 +0800
 
182
@@ -47,7 +47,6 @@
 
183
 int
 
184
 main (int argc, char **argv)
 
185
 {
 
186
-  g_thread_init (NULL);
 
187
   g_type_init ();
 
188
 
 
189
   test_extract_token ();
 
190
Index: librest-0.7.12/tests/proxy-continuous.c
 
191
===================================================================
 
192
--- librest-0.7.12.orig/tests/proxy-continuous.c        2012-05-27 21:38:06.167613589 +0800
 
193
+++ librest-0.7.12/tests/proxy-continuous.c     2012-05-27 21:38:16.611431356 +0800
 
194
@@ -168,7 +168,6 @@
 
195
   char *url;
 
196
   RestProxy *proxy;
 
197
 
 
198
-  g_thread_init (NULL);
 
199
   g_type_init ();
 
200
   loop = g_main_loop_new (NULL, FALSE);
 
201
 
 
202
Index: librest-0.7.12/tests/proxy.c
 
203
===================================================================
 
204
--- librest-0.7.12.orig/tests/proxy.c   2012-05-27 21:38:06.167613589 +0800
 
205
+++ librest-0.7.12/tests/proxy.c        2012-05-27 21:38:16.611431356 +0800
 
206
@@ -283,7 +283,6 @@
 
207
   char *url;
 
208
   RestProxy *proxy;
 
209
 
 
210
-  g_thread_init (NULL);
 
211
   g_type_init ();
 
212
 
 
213
   session = soup_session_async_new ();
 
214
Index: librest-0.7.12/tests/threaded.c
 
215
===================================================================
 
216
--- librest-0.7.12.orig/tests/threaded.c        2012-05-27 21:38:06.167613589 +0800
 
217
+++ librest-0.7.12/tests/threaded.c     2012-05-27 21:38:16.611431356 +0800
 
218
@@ -85,7 +85,6 @@
 
219
   char *url;
 
220
   int i;
 
221
 
 
222
-  g_thread_init (NULL);
 
223
   g_type_init ();
 
224
 
 
225
   session = soup_session_sync_new ();
 
226
Index: librest-0.7.12/tests/xml.c
 
227
===================================================================
 
228
--- librest-0.7.12.orig/tests/xml.c     2012-05-27 21:38:06.167613589 +0800
 
229
+++ librest-0.7.12/tests/xml.c  2012-05-27 21:38:16.611431356 +0800
 
230
@@ -33,7 +33,6 @@
 
231
   RestXmlNode *root, *node;
 
232
   char *xml;
 
233
 
 
234
-  g_thread_init (NULL);
 
235
   g_type_init ();
 
236
 
 
237
   parser = rest_xml_parser_new ();