~ubuntu-branches/ubuntu/vivid/libxml-bare-perl/vivid

« back to all changes in this revision

Viewing changes to debian/patches/implicit_declaration_of_free.patch

  • Committer: Package Import Robot
  • Author(s): Nuno Carvalho, gregor herrmann, Salvatore Bonaccorso, Axel Beckert, Nuno Carvalho
  • Date: 2013-09-17 15:54:28 UTC
  • mfrom: (1.1.4)
  • Revision ID: package-import@ubuntu.com-20130917155428-4d0xb5cissw2323f
Tags: 0.53-1
* Team upload.

[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.

[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs

[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
  copyright"

[ Nuno Carvalho ]
* New upstream release.
* debian/copyright: update copyright years.
* debian/control: update standards version.
* debian/control: update debhelper required version, in order to pass all
  the hardening flags to EUMM.
* Add lintian override to apparently false-positive warning.
* Add set of patches accepted upstream but still not included in this
  release, visit https://rt.cpan.org/Public/Bug/Display.html?id=88155
  for details.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: fix warning "incompatible implicit declaration of built-in function 'free'"
 
2
 by unconditionally including stdlib.h (required on Linux)
 
3
Author: Florian Schlichting <fsfs@debian.org>
 
4
 
 
5
--- a/parser.c
 
6
+++ b/parser.c
 
7
@@ -1,8 +1,6 @@
 
8
 #include "parser.h"
 
9
 #include<stdio.h>
 
10
-#ifdef DARWIN
 
11
-  #include "stdlib.h"
 
12
-#endif
 
13
+#include "stdlib.h"
 
14
 #ifdef NOSTRING
 
15
   void memset(char *s, int c, int n) {
 
16
     char *se = s + n;