~ubuntu-branches/ubuntu/vivid/liferea/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/libindicate.patch

  • Committer: Package Import Robot
  • Author(s): Ken VanDine
  • Date: 2012-02-10 14:13:54 UTC
  • Revision ID: package-import@ubuntu.com-20120210141354-i1xv5ht90iagdoi7
Tags: 1.6.6b-0ubuntu4
* debian/patches/libindicate.patch
  - pkgconfig update for indicate-0.7
* debian/control
  - bumped build depends for libindicate-dev to 0.6.90

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: liferea-ubuntu/configure.ac
 
1
Index: liferea-1.6.6b/configure.ac
2
2
===================================================================
3
 
--- liferea-ubuntu.orig/configure.ac    2011-08-10 23:11:11.654309000 -0400
4
 
+++ liferea-ubuntu/configure.ac 2011-08-10 23:18:16.625899496 -0400
 
3
--- liferea-1.6.6b.orig/configure.ac    2011-06-22 11:16:24.000000000 -0400
 
4
+++ liferea-1.6.6b/configure.ac 2012-02-10 14:13:15.637228619 -0500
5
5
@@ -28,6 +28,7 @@
6
6
 AC_ARG_ENABLE(dbus,      AS_HELP_STRING([--disable-dbus],[compile without DBUS support]),,enable_dbus=yes)
7
7
 AC_ARG_ENABLE(nm,        AS_HELP_STRING([--disable-nm],[compile without NetworkManager support]),,enable_nm=yes)
19
19
+dnl *********
20
20
+
21
21
+if test "x$enable_libindicate" = "xyes"; then
22
 
+   PKG_CHECK_MODULES([LIBINDICATE], indicate-0.6 indicate-gtk-0.6,enable_libindicate=yes,enable_libindicate=no)
 
22
+   PKG_CHECK_MODULES([LIBINDICATE], indicate-0.7 indicate-gtk-0.7,enable_libindicate=yes,enable_libindicate=no)
23
23
+   AC_SUBST(LIBINDICATE_CFLAGS)
24
24
+   AC_SUBST(LIBINDICATE_LIBS)
25
25
+else
35
35
 dnl *****
36
36
 dnl AVAHI
37
37
 dnl *****
38
 
@@ -240,6 +259,7 @@
 
38
@@ -241,6 +260,7 @@
39
39
 echo "Use X Session Management........ : $enable_sm"
40
40
 echo "Use DBUS........................ : $enable_dbus"
41
41
 echo "Use NetworkManager.............. : $enable_nm"
43
43
 dnl echo "AVAHI Support................... : $enable_avahi"
44
44
 echo
45
45
 eval eval echo Liferea will be installed in $bindir.
46
 
Index: liferea-ubuntu/src/Makefile.am
 
46
Index: liferea-1.6.6b/src/Makefile.am
47
47
===================================================================
48
 
--- liferea-ubuntu.orig/src/Makefile.am 2011-08-10 23:11:11.654309000 -0400
49
 
+++ liferea-ubuntu/src/Makefile.am      2011-08-10 23:17:29.495830366 -0400
 
48
--- liferea-1.6.6b.orig/src/Makefile.am 2011-06-22 09:25:40.000000000 -0400
 
49
+++ liferea-1.6.6b/src/Makefile.am      2012-02-10 14:12:48.385227722 -0500
50
50
@@ -91,3 +91,9 @@
51
51
 liferea_LDFLAGS = -Wl,--export-all-symbols,--out-implib,liferea.a
52
52
 
57
57
+liferea_LDADD += $(LIBINDICATE_LIBS)
58
58
+
59
59
+endif
60
 
Index: liferea-ubuntu/src/ui/liferea_shell.c
 
60
Index: liferea-1.6.6b/src/ui/liferea_shell.c
61
61
===================================================================
62
 
--- liferea-ubuntu.orig/src/ui/liferea_shell.c  2011-08-10 23:11:11.654309000 -0400
63
 
+++ liferea-ubuntu/src/ui/liferea_shell.c       2011-08-10 23:17:29.585830499 -0400
 
62
--- liferea-1.6.6b.orig/src/ui/liferea_shell.c  2012-02-10 14:05:00.000000000 -0500
 
63
+++ liferea-1.6.6b/src/ui/liferea_shell.c       2012-02-10 14:12:48.361227720 -0500
64
64
@@ -46,6 +46,7 @@
65
65
 #include "ui/liferea_dialog.h"
66
66
 #include "ui/ui_common.h"
78
78
                liferea_shutdown ();
79
79
                return TRUE;
80
80
        }
81
 
@@ -1264,6 +1265,8 @@
 
81
@@ -1277,6 +1278,8 @@
82
82
        shell->priv->feedlist = feedlist_create ();
83
83
        
84
84
        ui_tray_enable (conf_get_bool_value (SHOW_TRAY_ICON));          /* init tray icon */
87
87
 
88
88
        liferea_shell_restore_state ();
89
89
        
90
 
@@ -1329,6 +1332,7 @@
 
90
@@ -1342,6 +1345,7 @@
91
91
 {
92
92
        ui_feedlist_select (NULL);
93
93
        liferea_shell_save_position ();
95
95
        ui_tray_enable (FALSE);
96
96
        notification_enable (FALSE);
97
97
        g_object_unref (shell->priv->tabs);
98
 
@@ -1346,6 +1350,7 @@
 
98
@@ -1359,6 +1363,7 @@
99
99
                liferea_shell_restore_position ();
100
100
 
101
101
        gtk_window_present (shell->priv->window);
103
103
 }
104
104
 
105
105
 void
106
 
Index: liferea-ubuntu/src/ui/Makefile.am
 
106
Index: liferea-1.6.6b/src/ui/Makefile.am
107
107
===================================================================
108
 
--- liferea-ubuntu.orig/src/ui/Makefile.am      2011-08-10 23:11:11.654309000 -0400
109
 
+++ liferea-ubuntu/src/ui/Makefile.am   2011-08-10 23:17:29.515830403 -0400
 
108
--- liferea-1.6.6b.orig/src/ui/Makefile.am      2012-02-10 14:05:00.000000000 -0500
 
109
+++ liferea-1.6.6b/src/ui/Makefile.am   2012-02-10 14:12:48.305227719 -0500
110
110
@@ -8,7 +8,7 @@
111
111
 
112
112
 noinst_LIBRARIES = libliui.a
124
124
        ui_itemlist.c ui_itemlist.h \
125
125
        ui_node.c ui_node.h \
126
126
        ui_popup.c ui_popup.h \
127
 
Index: liferea-ubuntu/src/ui/ui_indicator.c
 
127
Index: liferea-1.6.6b/src/ui/ui_indicator.c
128
128
===================================================================
129
129
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
130
 
+++ liferea-ubuntu/src/ui/ui_indicator.c        2011-08-10 23:11:11.654309000 -0400
 
130
+++ liferea-1.6.6b/src/ui/ui_indicator.c        2012-02-10 14:05:00.000000000 -0500
131
131
@@ -0,0 +1,195 @@
132
132
+/*
133
133
+ * @file ui_indicator.c  libindicate support
324
324
+gboolean ui_indicator_is_visible () { return FALSE; }
325
325
+
326
326
+#endif  /* HAVE_LIBINDICATE */
327
 
Index: liferea-ubuntu/src/ui/ui_indicator.h
 
327
Index: liferea-1.6.6b/src/ui/ui_indicator.h
328
328
===================================================================
329
329
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
330
 
+++ liferea-ubuntu/src/ui/ui_indicator.h        2011-08-10 23:11:11.654309000 -0400
 
330
+++ liferea-1.6.6b/src/ui/ui_indicator.h        2012-02-10 14:05:00.000000000 -0500
331
331
@@ -0,0 +1,35 @@
332
332
+/*
333
333
+ * @file ui_indicator.h  libindicate support
364
364
+gboolean ui_indicator_is_visible ();
365
365
+
366
366
+#endif  /* _UI_INDICATOR_H */
367
 
Index: liferea-ubuntu/src/ui/ui_prefs.c
 
367
Index: liferea-1.6.6b/src/ui/ui_prefs.c
368
368
===================================================================
369
 
--- liferea-ubuntu.orig/src/ui/ui_prefs.c       2011-08-10 23:11:11.654309000 -0400
370
 
+++ liferea-ubuntu/src/ui/ui_prefs.c    2011-08-10 23:11:11.654309000 -0400
 
369
--- liferea-1.6.6b.orig/src/ui/ui_prefs.c       2012-02-10 14:05:00.000000000 -0500
 
370
+++ liferea-1.6.6b/src/ui/ui_prefs.c    2012-02-10 14:05:00.000000000 -0500
371
371
@@ -767,9 +767,15 @@
372
372
                widget = liferea_dialog_lookup (prefdialog, "popupwindowsoptionbtn");
373
373
                gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (widget), conf_get_bool_value (SHOW_POPUP_WINDOWS));
399
399
                /* tool bar settings */ 
400
400
                widget = liferea_dialog_lookup (prefdialog, "hidetoolbarbtn");
401
401
                gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (widget), conf_get_bool_value(DISABLE_TOOLBAR));
402
 
Index: liferea-ubuntu/src/ui/ui_tray.c
 
402
Index: liferea-1.6.6b/src/ui/ui_tray.c
403
403
===================================================================
404
 
--- liferea-ubuntu.orig/src/ui/ui_tray.c        2011-08-10 23:11:11.654309000 -0400
405
 
+++ liferea-ubuntu/src/ui/ui_tray.c     2011-08-10 23:17:29.545830446 -0400
 
404
--- liferea-1.6.6b.orig/src/ui/ui_tray.c        2012-02-10 14:05:00.000000000 -0500
 
405
+++ liferea-1.6.6b/src/ui/ui_tray.c     2012-02-10 14:12:48.325227720 -0500
406
406
@@ -35,6 +35,7 @@
407
407
 #include "net.h"
408
408
 #include "ui/liferea_shell.h"