~ubuntu-branches/ubuntu/vivid/morse/vivid

« back to all changes in this revision

Viewing changes to debian/patches/00makefile

  • Committer: Bazaar Package Importer
  • Author(s): Nanakos Chrysostomos
  • Date: 2010-05-19 01:04:44 UTC
  • Revision ID: james.westby@ubuntu.com-20100519010444-frth5pbu83x5gs3w
Tags: 2.1-4
* New package maintainer. (Closes: Bug#553991).
* Lintian cleaning.
* Updated S-V to 3.8.4
    - debian/copyright file is now UTF-8 encoded.
* Added co-authors to debian/copyright file.
* Added ${misc:Depends} to conrol file.
* Added debian/source/format file.
* Removed "-" from rules file because the package uses
  a static makefile.
* Bumped debhelper versioned Build-Depends to 7, and updated
  debian/compat.
* Extracted changes to upstream files to debian/patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Minor changes for the new version of morse package.
 
2
Author: Nanakos Chrysostomos <nanakos@wired-net.gr>
 
3
Bug-Debian: http://bugs.debian.org/553991
 
4
 
 
5
--- morse-2.1.orig/Makefile
 
6
+++ morse-2.1/Makefile
 
7
@@ -23,8 +23,8 @@
 
8
 # to the authors!
 
9
 #
 
10
 #DEVICE = X11
 
11
-#DEVICE = Linux
 
12
-DEVICE = OSS
 
13
+DEVICE = Linux
 
14
+#DEVICE = OSS
 
15
 
 
16
 VERS=$(shell sed <morse.spec -n -e '/Version: \(.*\)/s//\1/p')
 
17
 
 
18
@@ -39,13 +39,18 @@ default:
 
19
 
 
20
 all: morse QSO morse.1 QSO.1
 
21
 
 
22
+install: all
 
23
+       install morse.d/morseLinux $(DESTDIR)/usr/bin/morse
 
24
+       install morse.d/morseX11 $(DESTDIR)/usr/bin
 
25
+       install qso.d/QSO $(DESTDIR)/usr/bin
 
26
+
 
27
 morse:
 
28
-       cd morse.d && make DEVICE=${DEVICE}
 
29
-       ln morse.d/morse ./morse
 
30
+#      cd morse.d && make DEVICE=${DEVICE}
 
31
+#      ln morse.d/morse ./morse
 
32
 
 
33
 QSO:
 
34
        cd qso.d && make
 
35
-       ln qso.d/QSO ./QSO
 
36
+#      ln qso.d/QSO ./QSO
 
37
 
 
38
 #
 
39
 # "Jocks find quartz glyph, vex BMW." is my attempt to win Stephen J. Gould's
 
40
@@ -56,10 +61,10 @@ QSO:
 
41
 # he did say it's the closest he's seen so far. - Joe Dellinger
 
42
 #
 
43
 testmorse:     morse QSO
 
44
-       (cat test_input; qso.d/QSO) | morse -w 24 -l -e
 
45
+#      (cat test_input; qso.d/QSO) | morse -w 24 -l -e
 
46
 
 
47
 testqso:       morse QSO
 
48
-       qso.d/QSO | ./morse -w 20 -l -e
 
49
+#      qso.d/QSO | ./morse -w 20 -l -e
 
50
 
 
51
 all:   morse QSO
 
52