~ubuntu-branches/ubuntu/vivid/mutt/vivid-updates

« back to all changes in this revision

Viewing changes to debian/patches/mutt-patched/sidebar

  • Committer: Package Import Robot
  • Author(s): Antonio Radici
  • Date: 2011-04-11 16:23:35 UTC
  • Revision ID: package-import@ubuntu.com-20110411162335-t8iu29pnqzgpql5w
Tags: 1.5.21-4
* debian/paches:
  + mutt-patched/sidebar: added a closedir() so the fds will not be starved 
    (Closes: 620854)
  + upstream/620854-pop3-segfault.patch: prevent segfault when
    $message_cachedir is set and a pop3 mailbox is open (Closes: 620854)
* debian/control:
  + Standards-Version upgraded to 3.9.2.0, no changes required

Show diffs side-by-side

added added

removed removed

Lines of Context:
53
53
       rc = 1;
54
54
       break;
55
55
     }
56
 
@@ -337,6 +343,32 @@
 
56
@@ -337,6 +343,34 @@
57
57
 
58
58
   closedir (dirp);
59
59
 
83
83
+    }
84
84
+  }
85
85
+
 
86
+  closedir (dirp);
 
87
+
86
88
   return rc;
87
89
 }
88
90
 
89
 
@@ -345,14 +377,33 @@
 
91
@@ -345,14 +379,33 @@
90
92
 {
91
93
   int rc = 0;
92
94
   int statcheck;
121
123
     if (!option(OPTMAILCHECKRECENT) || sb->st_mtime > mailbox->last_visited)
122
124
     {
123
125
       rc = 1;
124
 
@@ -374,9 +425,11 @@
 
126
@@ -374,9 +427,11 @@
125
127
 int mutt_buffy_check (int force)
126
128
 {
127
129
   BUFFY *tmp;
133
135
 
134
136
   sb.st_size=0;
135
137
   contex_sb.st_dev=0;
136
 
@@ -456,6 +509,20 @@
 
138
@@ -456,6 +511,20 @@
137
139
       case M_MH:
138
140
        if ((tmp->new = mh_buffy (tmp->path)) > 0)
139
141
          BuffyCount++;
1304
1306
 # Name: crypt_autosign
1305
1307
--- a/imap/imap.c
1306
1308
+++ b/imap/imap.c
1307
 
@@ -1521,7 +1521,7 @@
 
1309
@@ -1527,7 +1527,7 @@
1308
1310
 
1309
1311
     imap_munge_mbox_name (munged, sizeof (munged), name);
1310
1312
     snprintf (command, sizeof (command),