~ubuntu-branches/ubuntu/vivid/net-dns-fingerprint/vivid

« back to all changes in this revision

Viewing changes to debian/patches/01-Fingerprint.pm

  • Committer: Bazaar Package Importer
  • Author(s): Thorsten Alteholz
  • Date: 2009-10-09 18:00:00 UTC
  • Revision ID: james.westby@ubuntu.com-20091009180000-jqm13awijpkjs9lz
Tags: 0.9.3-3
* new maintainer (closes: #508842)
* debian/control: moved Homepage: field from description to header
* debian/control: changed Homepage: to new URL
* debian/rules: no upstream changelog -> used debian/changelog
* debian/rules: nothing to do for binary arch, so removed it
* debian/compat changed from 4 to 5
* watch file added
* changes in src moved to patches
* debian/README.source added
* debian/control: standards raised from 3.6.2 to 3.8.3 (no change required)
* debian/control: changed priority from extra to optional
* debian/control: changed typo in description (closes: #343707)
* applied patch from Thomas Parmelan (closes: #548307)
* Fingerprint.pm: - marked NLD versions as uncertain (closes: #282096)
                  - changed bind entries to latest version

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01-Fingerprint.pm patch made by <debian@alteholz.de>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: 
 
6
 
 
7
 
 
8
@DPATCH@
 
9
 
 
10
--- Net-DNS-Fingerprint-0.9.3/Fingerprint.pm    2005-09-05 15:33:36.000000000 +0200
 
11
+++ net-dns-fingerprint-0.9.3/Fingerprint.pm    2009-10-08 22:23:37.000000000 +0200
 
12
@@ -46,6 +46,7 @@
 
13
     debug    => 0,
 
14
     qversion => 0,
 
15
     qchaos   => 0,
 
16
+    separator => " ",
 
17
 );
 
18
 
 
19
 my $versionlength = 40;
 
20
@@ -470,7 +471,7 @@
 
21
 
 
22
     push @s, "($r{state};$r{id})" if($self->{debug});
 
23
 
 
24
-    return join(" ", @s);
 
25
+    return join($self->{separator}, @s);
 
26
 }
 
27
 
 
28
 sub query_version