~ubuntu-branches/ubuntu/vivid/parmap/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0003-ALIBS-should-be-built-only-on-native-archs.patch

  • Committer: Package Import Robot
  • Author(s): Mehdi Dogguy
  • Date: 2014-10-09 15:16:11 UTC
  • Revision ID: package-import@ubuntu.com-20141009151611-4ptqjh0ajt6ylk9n
Tags: 1.0~rc4-3
* Do not build ALIBS (parmap.a) on bytecode architectures.
  - add 0003-ALIBS-should-be-built-only-on-native-archs.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Mehdi Dogguy <mehdi@debian.org>
 
2
Date: Thu, 9 Oct 2014 15:13:19 +0200
 
3
Subject: ALIBS should be built only on native archs
 
4
 
 
5
---
 
6
 Makefile.in |    3 +--
 
7
 1 file changed, 1 insertion(+), 2 deletions(-)
 
8
 
 
9
diff --git a/Makefile.in b/Makefile.in
 
10
index 3fda420..373ebc6 100644
 
11
--- a/Makefile.in
 
12
+++ b/Makefile.in
 
13
@@ -43,10 +43,9 @@ ALIBS=
 
14
 ifeq ($(OCAMLBEST),native)
 
15
   OPTLIBS += $(BYTELIBS:%.cma=%.cmxa)
 
16
   CMXSLIBS += $(BYTELIBS:%.cma=%.cmxs)
 
17
+  ALIBS = $(BYTELIBS:%.cma=%.a)
 
18
 endif
 
19
 
 
20
-ALIBS = $(BYTELIBS:%.cma=%.a)
 
21
-
 
22
 all:
 
23
        $(OCAMLBUILD) $(OBFLAGS) $(BYTELIBS) $(OPTLIBS) $(CMXSLIBS) $(ALIBS)
 
24
 
 
25
--