~ubuntu-branches/ubuntu/vivid/parted/vivid

« back to all changes in this revision

Viewing changes to debian/patches/gptsync.patch

  • Committer: Package Import Robot
  • Author(s): Colin Watson
  • Date: 2013-06-17 18:42:45 UTC
  • mfrom: (118.1.4 parted)
  • Revision ID: package-import@ubuntu.com-20130617184245-oau328d35jlr2ytx
Tags: 2.3-13ubuntu2
* Remove tests/Makefile.in from debian/patches/gptsync.patch; this must
  not be present now that we're using dh-autoreconf.
* Backport upstream patches to handle GPT labels with fewer than 128
  partition entries (LP: #1187560).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
From: Matthew Garrett <mjg59@srcf.ucam.org>
2
2
From: Colin Watson <cjwatson@ubuntu.com>
3
3
Forwarded: no
4
 
Last-Update: 2012-03-08
 
4
Last-Update: 2013-06-06
5
5
Description: GPT syncing for Intel Macs
6
6
 On Intel Mac systems, write a synced MBR rather than a protective MBR.
7
7
 
30
30
 #include <fcntl.h>
31
31
 #include <unistd.h>
32
32
 #include <uuid/uuid.h>
33
 
@@ -282,6 +289,258 @@
 
33
@@ -287,6 +294,258 @@
34
34
 
35
35
 static PedDiskType gpt_disk_type;
36
36
 
289
289
 static inline uint32_t
290
290
 pth_get_size (const PedDevice *dev)
291
291
 {
292
 
@@ -476,6 +735,9 @@
 
292
@@ -481,6 +740,9 @@
293
293
   if (!gpt_sig_found)
294
294
     return 0;
295
295
 
299
299
   void *label;
300
300
   if (!ptt_read_sector (dev, 0, &label))
301
301
     return 0;
302
 
@@ -889,6 +1151,10 @@
 
302
@@ -897,6 +1159,10 @@
303
303
  *  warn if it's not there, and treat the disk as MSDOS, with a note
304
304
  *  for users to use Parted to "fix up" their disk if they
305
305
  *  really want it to be considered GPT.
310
310
  ************************************************************/
311
311
 static int
312
312
 gpt_read (PedDisk *disk)
313
 
@@ -1095,6 +1361,129 @@
 
313
@@ -1103,6 +1369,129 @@
314
314
   return write_ok;
315
315
 }
316
316
 
440
440
 static int
441
441
 _generate_header (const PedDisk *disk, int alternate, uint32_t ptes_crc,
442
442
                   GuidPartitionTableHeader_t **gpt_p)
443
 
@@ -1201,9 +1590,15 @@
 
443
@@ -1211,9 +1600,15 @@
444
444
 
445
445
   ptes_crc = efi_crc32 (ptes, ptes_size);
446
446
 
459
459
 
460
460
   /* Write PTH and PTEs */
461
461
   /* FIXME: Caution: this code is nearly identical to what's just below. */
462
 
@@ -1790,6 +2185,21 @@
 
462
@@ -1805,6 +2200,21 @@
463
463
   PED_ASSERT (sizeof (GuidPartitionEntry_t) == 128, return);
464
464
 
465
465
   ped_disk_type_register (&gpt_disk_type);
673
673
   t0300-dos-on-gpt.sh \
674
674
   t0400-loop-clobber-infloop.sh \
675
675
   t0500-dup-clobber.sh \
676
 
Index: b/tests/Makefile.in
677
 
===================================================================
678
 
--- a/tests/Makefile.in
679
 
+++ b/tests/Makefile.in
680
 
@@ -927,6 +927,7 @@
681
 
   t0220-gpt-msftres.sh \
682
 
   t0250-gpt.sh \
683
 
   t0280-gpt-corrupt.sh \
684
 
+  t0290-gptsync.sh \
685
 
   t0300-dos-on-gpt.sh \
686
 
   t0400-loop-clobber-infloop.sh \
687
 
   t0500-dup-clobber.sh \
688
 
@@ -1353,6 +1354,8 @@
689
 
        @p='t0250-gpt.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
690
 
 t0280-gpt-corrupt.sh.log: t0280-gpt-corrupt.sh
691
 
        @p='t0280-gpt-corrupt.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
692
 
+t0290-gptsync.sh.log: t0290-gptsync.sh
693
 
+       @p='t0290-gptsync.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
694
 
 t0300-dos-on-gpt.sh.log: t0300-dos-on-gpt.sh
695
 
        @p='t0300-dos-on-gpt.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
696
 
 t0400-loop-clobber-infloop.sh.log: t0400-loop-clobber-infloop.sh