~ubuntu-branches/ubuntu/vivid/projectcenter.app/vivid

« back to all changes in this revision

Viewing changes to debian/patches/gui-0.22.patch

  • Committer: Package Import Robot
  • Author(s): Yavor Doganov
  • Date: 2012-06-04 19:47:30 UTC
  • mfrom: (3.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20120604194730-35r939la9onc2qhf
Tags: 0.6.0-2
* debian/patches/05_link-libs.dpatch: Rename as...
* debian/patches/link-libs.patch: ...and remove dpatch header.
* debian/patches/gui-0.22.patch: New; fixes FTBFS with gnustep-gui/0.22
  (Closes: #674920).
* debian/patches/00list: Rename as...
* debian/patches/series: ...and update.
* debian/source/format: Switch to 3.0 (quilt).
* debian/README.source: Delete; redundant.
* debian/control (Build-Depends): Remove dpatch.  Add dpkg-dev (>=
  1.16.1~), for hardening support.
  (Recommends): Add gdb.
  (Vcs-Arch): Replace with...
  (Vcs-Git): Since the package is now maintained with Git.
  (Vcs-Browser): New field.
  (Standards-Version): Bump to 3.9.3; no changes needed.
* debian/rules: Don't include /usr/share/dpatch/dpatch.make.  Remove
  patch/unpatch dependencies.  Enable hardening.
  (binary-arch): Remove GS_USE_FHS conditional.
* debian/preinst: Delete; no longer needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
2011-09-08  Riccardo Mottola  <rm@gnu.org>
 
2
 
 
3
        * Framework/PCAddFilesPanel.m [-setFileTypes]: Use
 
4
          setAllowedFileTypes method instead of private method which
 
5
          was removed.
 
6
 
 
7
2011-04-07  Riccardo Mottola  <rm@gnu.org>
 
8
 
 
9
        * Headers/ProjectCenter/PCDefines.h: Change ifdef to detect
 
10
          non-gnustep.
 
11
 
 
12
 
 
13
--- projectcenter.app.orig/Framework/PCAddFilesPanel.m
 
14
+++ projectcenter.app/Framework/PCAddFilesPanel.m
 
15
@@ -93,7 +93,7 @@
 
16
 {
 
17
   NSString  *path = nil;
 
18
 
 
19
-  ASSIGN(_fileTypes, fileTypes);
 
20
+  [super setAllowedFileTypes: fileTypes];
 
21
 
 
22
   path = [_browser path];
 
23
   [self validateVisibleColumns];
 
24
--- projectcenter.app.orig/Headers/ProjectCenter/PCDefines.h
 
25
+++ projectcenter.app/Headers/ProjectCenter/PCDefines.h
 
26
@@ -46,7 +46,7 @@
 
27
 //=============================================================================
 
28
 // ==== MacOS X portability defines
 
29
 //=============================================================================
 
30
-#ifndef GNUSTEP_BASE_VERSION
 
31
+#ifndef GNUSTEP
 
32
 
 
33
 #define RETAIN(object)          [object retain]
 
34
 #define RELEASE(object)         [object release]