~ubuntu-branches/ubuntu/vivid/rtfilter/vivid

« back to all changes in this revision

Viewing changes to debian/patches/fix-echoterm-after-test.patch

  • Committer: Package Import Robot
  • Author(s): Nicolas Bourdaud
  • Date: 2011-12-01 12:09:30 UTC
  • Revision ID: package-import@ubuntu.com-20111201120930-wz8ubij1u6ri4t62
Tags: 1.1-1
* Update maintainer email 
* Switch to "3.0 (quilt)" source package format 
* DEP5 compliant debian/copyright 
* Install all docs in doc folder of librtfilter1 
* Install NEWS, AUTHORS and README in doc folder
* Tighten build-dependency on debhelper to >= 7.0.50~ due to override_
  rules.
* Bump Standards-version to 3.9.2 
* Provides a -dbg package 
* Update optional fields in control (Vcs-Git, Vcs-Browser, Homepage) 
* Add debian/watch 
* Use DEB_*_MAINT_* to specify compiler and linker flags.
* Fix terminal echo after running test 
* Only provide an unversioned librtfilter-dev package. 
* Use dh-autoreconf 
* patch: make matlab tests user-controllable
* disable matlab tests
* Update package description
* patch: move config.h into src/
* Build-depends on dpkg-dev (>= 1.16.1~): necessary for the inclusion
  of /usr/share/dpkg/buildflags.mk in debian/rules
* Fix debclean: remove src/config.h and src/stamp-h1 manually.

* Upload sponsored by Michael Hanke <mih@debian.org>
* Initial release. (Closes: #646956) 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix terminal echo after runnning test
 
2
 Running recent version of matlab (used in the test when available) modify
 
3
 setting of the terminal. This reset them after the test is run.
 
4
Forwarded: yes
 
5
Author: Nicolas Bourdaud <nicolas.bourdaud@gmail.com>
 
6
Applied-Upstream: commit: e6a0ed8e8da59398a20ea3d2fba1dc7ec4f1926d
 
7
--- a/tests/test-complex-double.sh
 
8
+++ b/tests/test-complex-double.sh
 
9
@@ -12,7 +12,9 @@
 
10
 } > $LOGFILE 
 
11
 then
 
12
        rm $LOGFILE
 
13
+       stty echo
 
14
        exit 0
 
15
 else
 
16
+       stty echo
 
17
        exit 1
 
18
 fi
 
19
--- a/tests/test-complex-float.sh
 
20
+++ b/tests/test-complex-float.sh
 
21
@@ -12,7 +12,9 @@
 
22
 } > $LOGFILE
 
23
 then
 
24
        rm $LOGFILE
 
25
+       stty echo
 
26
        exit 0
 
27
 else
 
28
+       stty echo
 
29
        exit 1
 
30
 fi
 
31
--- a/tests/test-double.sh
 
32
+++ b/tests/test-double.sh
 
33
@@ -8,7 +8,9 @@
 
34
 } > $LOGFILE
 
35
 then
 
36
        rm $LOGFILE
 
37
+       stty echo
 
38
        exit 0
 
39
 else
 
40
+       stty echo
 
41
        exit 1
 
42
 fi
 
43
--- a/tests/test-downsample.sh
 
44
+++ b/tests/test-downsample.sh
 
45
@@ -8,7 +8,9 @@
 
46
 } > $LOGFILE
 
47
 then
 
48
        rm $LOGFILE
 
49
+       stty echo
 
50
        exit 0
 
51
 else
 
52
+       stty echo
 
53
        exit 1
 
54
 fi
 
55
--- a/tests/test-float.sh
 
56
+++ b/tests/test-float.sh
 
57
@@ -8,7 +8,9 @@
 
58
 } > $LOGFILE
 
59
 then
 
60
        rm $LOGFILE
 
61
+       stty echo
 
62
        exit 0
 
63
 else
 
64
+       stty echo
 
65
        exit 1
 
66
 fi