~ubuntu-branches/ubuntu/vivid/ruby-mixlib-authentication/vivid

« back to all changes in this revision

Viewing changes to debian/patches/01_fix_http_authentication_request_spec.diff

  • Committer: Package Import Robot
  • Author(s): Paul van Tilburg
  • Date: 2012-05-17 13:56:37 UTC
  • Revision ID: package-import@ubuntu.com-20120517135637-y2wh4batzt0ws5dh
Tags: 1.1.4-1
* New upstream release.
* Source packages adapted according to the new Ruby policy (closes: #653359):
  - Build for both ruby1.8 and ruby1.9.1.
  - Migrated to pkg-ruby-extras git repos. Changed the Vcs-* fields in
    debian/control accordingly.
  - Changed the depends and recommends to follow the new Ruby library
    naming scheme.
* debian/control:
  - Added a default DM-Upload-Allowed field set to yes.
  - Standards-Version bumped to 3.9.3; no changes required.
  - Set XS-Ruby-Versions to all.
  - Changed the build-depends for using gem2deb instead of ruby-pkg-tools.
  - Added libmixlib-authentication-ruby and
    libmixlib-authentication-ruby1.8 as transitional packages.
  - Added a build-depend on ruby-rspec for the test suite.
* debian/copyright: reworked to fit the Debian copyright format version 1.0.
* debian/patches: added 01_fix_http_authentication_request_spec.diff to
  fix an issue with a test.
* debian/source/local-options:  set "unapply-patches" to unapply patches
  after build.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix for HTTP authentication test
 
2
  This fix is supplied by upstream to repair an issue with a HTTP
 
3
  authentication spec file.
 
4
  .
 
5
  The fix will be included in an upcoming upstream releases for which the
 
6
  date has not been set yet.
 
7
Forwarded: not-needed
 
8
Author: Chris Walters <github.algorist@ckwalters.com>
 
9
Origin: upstream, https://github.com/opscode/mixlib-authentication/commit/fe5cd0116d13982557fdc92355e493e3849a5e0e
 
10
 
 
11
--- a/spec/mixlib/authentication/http_authentication_request_spec.rb
 
12
+++ b/spec/mixlib/authentication/http_authentication_request_spec.rb
 
13
@@ -82,8 +82,7 @@
 
14
   it "raises an error when not all required headers are given" do
 
15
     @merb_headers.delete("HTTP_X_OPS_SIGN")
 
16
     exception = Mixlib::Authentication::MissingAuthenticationHeader
 
17
-    auth_req = Mixlib::Authentication::HTTPAuthenticationRequest.new(@request)
 
18
-    lambda {auth_req.validate_headers!}.should raise_error(exception)
 
19
+    lambda{ Mixlib::Authentication::HTTPAuthenticationRequest.new(@request) }.should raise_error(exception)
 
20
   end
 
21
 
 
22
   it "extracts the path from the request" do