~ubuntu-branches/ubuntu/vivid/sflphone/vivid

« back to all changes in this revision

Viewing changes to debian/patches/eds_fix_gcc_warnings.patch

  • Committer: Package Import Robot
  • Author(s): Mark Purcell
  • Date: 2013-06-30 11:40:56 UTC
  • mfrom: (4.1.18 saucy-proposed)
  • Revision ID: package-import@ubuntu.com-20130630114056-0np50jkyqo6vnmii
Tags: 1.2.3-2
* changeset_r92d62cfc54732bbbcfff2b1d36c096b120b981a5.diff 
  - fixes automatic endian detection 
* Update Vcs: fixes vcs-field-not-canonical

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
---
2
 
 plugins/addressbook/evolution/eds.c |    8 ++++++++
3
 
 plugins/configure.ac                |    2 +-
4
 
 2 files changed, 9 insertions(+), 1 deletion(-)
5
 
 
6
 
Index: b/plugins/addressbook/evolution/eds.c
7
 
===================================================================
8
 
--- a/plugins/addressbook/evolution/eds.c
9
 
+++ b/plugins/addressbook/evolution/eds.c
10
 
@@ -48,6 +48,14 @@
11
 
 #include <libedataserver/e-source.h>
12
 
 #endif
13
 
 
14
 
+#define GCC_VERSION (__GNUC__ * 10000 \
15
 
+        + __GNUC_MINOR__ * 100 \
16
 
+        + __GNUC_PATCHLEVEL__)
17
 
+/* Test for GCC < 4.7.0 */
18
 
+#if GCC_VERSION < 40700
19
 
+#pragma GCC diagnostic ignored "-Wmissing-field-initializers"
20
 
+#endif
21
 
+
22
 
 /**
23
 
  * Structure used to store search callback and data
24
 
  */
25
 
Index: b/plugins/configure.ac
26
 
===================================================================
27
 
--- a/plugins/configure.ac
28
 
+++ b/plugins/configure.ac
29
 
@@ -23,7 +23,7 @@ AC_PROG_INSTALL
30
 
 AC_HEADER_STDC
31
 
 LT_INIT
32
 
 
33
 
-MIGRATION_FLAGS="-DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGTK_DISABLE_SINGLE_INCLUDES"
34
 
+MIGRATION_FLAGS="-DE_BOOK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGTK_DISABLE_SINGLE_INCLUDES"
35
 
 if test "x$with_debug" = "xfull" -o "x$with_debug" = "xyes"; then
36
 
     CFLAGS="-g -O0 -DDEBUG -Wall -Wextra $MIGRATION_FLAGS"
37
 
 else