~ubuntu-branches/ubuntu/vivid/wmsysmon/vivid

« back to all changes in this revision

Viewing changes to debian/patches/03-src_makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Luca Bedogni
  • Date: 2007-08-16 16:09:43 UTC
  • mfrom: (4.1.1 gutsy)
  • Revision ID: james.westby@ubuntu.com-20070816160943-17e6y17au2d1ndab
Tags: 0.7.7-7
* Added the watch file
* Deleted automatic strip (Closes: #438276)
* Modified debian/menu to move application in Apps/System/Monitoring 
* Modified debian/changelog for not ignoring errors on make clean.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02-src_makefile.dpatch by Luca Bedogni <me@lucabedogni.it>
 
3
##
 
4
## DP: Change Makefile to fit debian policy
 
5
 
 
6
@DPATCH@
 
7
 
 
8
--- wmsysmon-0.7.7/src/Makefile 2001-12-24 08:01:43.000000000 +0100
 
9
+++ wmsysmon-0.7.7/src/Makefile 2007-03-14 00:43:12.000000000 +0100
 
10
@@ -3,7 +3,7 @@
 
11
 LIBDIR += -L/usr/X11R6/lib
 
12
 LDFLAGS += -lXpm -lXext -lX11 -lm -s
 
13
 #CFLAGS = -g #-DMONDEBUG
 
14
-CFLAGS += -Wall -O3 -m486 -fomit-frame-pointer -I/usr/X11R6/include #-DHI_INTS #undefine HI_INTS if your x86 SMP or alpha
 
15
+CFLAGS += -Wall -O3 -fomit-frame-pointer -I/usr/X11R6/include #-DHI_INTS #undefine HI_INTS if your x86 SMP or alpha
 
16
 
 
17
 BIN = wmsysmon
 
18
 OBJS = wmgeneral.o \
 
19
@@ -17,5 +17,6 @@
 
20
 clean:
 
21
        rm -f $(OBJS) $(BIN)
 
22
 
 
23
-install:
 
24
-       install -g root -o root $(BIN) /usr/local/bin
 
25
+install: $(BIN)
 
26
+       mkdir -p $(DESTDIR)/usr/bin
 
27
+       install -g root -o root $(BIN) $(DESTDIR)/usr/bin