~ubuntu-branches/ubuntu/vivid/wxwidgets2.8/vivid

« back to all changes in this revision

Viewing changes to debian/patches/fix-build-with-python2.6.patch

  • Committer: Bazaar Package Importer
  • Author(s): Devid Antonio Filoni
  • Date: 2010-07-20 01:55:41 UTC
  • Revision ID: james.westby@ubuntu.com-20100720015541-f4j0v8g28tdvp9xj
Tags: 2.8.11.0-0ubuntu2
* Merge *some* changes from Debian package (version 2.8.10.1-3). This should
  make merges easier. Also fixes LP: #559822. Also merged several patches.
* Remove debian/patches/editra_pixmaps.dpatch patch, we don't ship editra
  anymore.
* Remove files which broke update-alternatives (LP: #379573).
* Switch to format 3.0 (quilt).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/wxPython/setup.py b/wxPython/setup.py
 
2
index d987c5d..ac1edde 100755
 
3
--- a/wxPython/setup.py
 
4
+++ b/wxPython/setup.py
 
5
@@ -1033,7 +1033,7 @@ if __name__ == "__main__":
 
6
 
 
7
               **other_kw
 
8
               )
 
9
-
 
10
+        BUILD_OPTIONS['build_base'] = BUILD_BASE + "-common"
 
11
         if not EGGing:
 
12
             if INSTALL_MULTIVERSION:
 
13
                 setup(name             = 'wxPython-common',
 
14
@@ -1048,7 +1048,7 @@ if __name__ == "__main__":
 
15
                       platforms        = PLATFORMS,
 
16
                       classifiers      = filter(None, CLASSIFIERS.split("\n")),
 
17
                       keywords         = KEYWORDS,
 
18
-
 
19
+                      packages = [''],
 
20
                       package_dir = { '': 'wxversion' },
 
21
                       py_modules = ['wxversion'],
 
22