~ubuntu-branches/ubuntu/wily/aesfix/wily

« back to all changes in this revision

Viewing changes to debian/patches/add-hardening

  • Committer: Package Import Robot
  • Author(s): Joao Eriberto Mota Filho
  • Date: 2015-06-16 23:13:09 UTC
  • mfrom: (3.1.1 experimental)
  • Revision ID: package-import@ubuntu.com-20150616231309-jqiosb9bwnep9hwc
Tags: 1.0.1-4
* Team upload.
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: add GCC hardening.
 
2
Author: Joao Eriberto Mota Filho <eriberto@debian.org>
 
3
Last-Update: 2015-02-23
 
4
Index: aesfix-1.0.1/Makefile
 
5
===================================================================
 
6
--- aesfix-1.0.1.orig/Makefile
 
7
+++ aesfix-1.0.1/Makefile
 
8
@@ -1,10 +1,10 @@
 
9
-CXXFLAGS= -Wall -O4 -funroll-loops
 
10
+CXXFLAGS += -Wall -O4 -funroll-loops
 
11
 OBJS= aesfix.o errvect.o
 
12
 
 
13
 all: aesfix
 
14
 
 
15
 aesfix: $(OBJS)
 
16
-       $(CXX) -o aesfix $(OBJS)
 
17
+       $(CXX) $(LDFLAGS) -o aesfix $(OBJS)
 
18
 
 
19
 clean:
 
20
        @rm -f aesfix *~ \#* $(OBJS)