~ubuntu-branches/ubuntu/wily/blueman/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/python_multiarch

  • Committer: Package Import Robot
  • Author(s): Jackson Doak
  • Date: 2014-01-21 08:54:58 UTC
  • mfrom: (2.3.4 sid)
  • Revision ID: package-import@ubuntu.com-20140121085458-riy3j6wk9vfd599j
Tags: 1.23-git201312311147-1ubuntu1
* Merge from debian unstable. Remaining changes:
  - debian/patches/01_dont_autostart_lxde.patch:
    + Don't autostart the applet in LXDE
  - debian/patches/02_dont_crash_on_non-bluetooth_card.patch:
    + Avoid crashing when receiving event for cards blueman shouldn't handle
  - debian/control: Don't depend on python-appindicator
  - debian/patches/03_filemanager_fix.patch:
    + Add support for more filemanagers 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Add python multiarch include dirs
2
 
 Use python-config to get proper include dirs
3
 
Author: Micah Gersten <micahg@ubuntu.com>
4
 
 
5
 
--- blueman-1.23.orig/acinclude.m4
6
 
+++ blueman-1.23/acinclude.m4
7
 
@@ -90,7 +90,7 @@ AC_MSG_CHECKING(for headers required to
8
 
 dnl deduce PYTHON_INCLUDES
9
 
 py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
10
 
 py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
11
 
-PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
12
 
+PYTHON_INCLUDES=`python-config --includes`
13
 
 if test "$py_prefix" != "$py_exec_prefix"; then
14
 
   PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
15
 
 fi