~ubuntu-branches/ubuntu/wily/clamav/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0005-configure.ac-patches-to-got-with-autoreconf-and-auto.patch

  • Committer: Package Import Robot
  • Author(s): Scott Kitterman
  • Date: 2014-03-15 12:47:13 UTC
  • mfrom: (0.35.39 sid)
  • Revision ID: package-import@ubuntu.com-20140315124713-xqgr3h376zqnw9yb
Tags: 0.98.1+dfsg-3ubuntu1
* Merge from Debian unstable.  Remaining changes:
  - Drop build-dep on electric-fence (in Universe)
  - Add apparmor profiles for clamd and freshclam along with maintainer
    script changes

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From cbdf7f7418d29942b7f367be843678e111a96518 Mon Sep 17 00:00:00 2001
 
2
From: Scott Kitterman <scott@kitterman.com>
 
3
Date: Mon, 10 Mar 2014 20:41:13 -0400
 
4
Subject: configure.ac patches to got with autoreconf and automake1.11
 
5
 
 
6
---
 
7
 configure.ac               | 3 ++-
 
8
 libclamav/c++/configure.ac | 3 ++-
 
9
 2 files changed, 4 insertions(+), 2 deletions(-)
 
10
 
 
11
diff --git a/configure.ac b/configure.ac
 
12
index 41df5d0..c9e3f97 100644
 
13
--- a/configure.ac
 
14
+++ b/configure.ac
 
15
@@ -34,8 +34,9 @@ AC_CREATE_TARGET_H([target.h])
 
16
 
 
17
 dnl -Wall and -Werror here are NOT CFLAGS, they refer to automake warnings
 
18
 dnl enable stealth builds and psychedelic tests
 
19
-AM_INIT_AUTOMAKE([1.11 -Wall -Wportability -Wno-override -Werror std-options foreign dist-bzip2 no-define color-tests parallel-tests tar-ustar])
 
20
+AM_INIT_AUTOMAKE([-Wall -Wportability -Wno-override -Werror std-options foreign dist-bzip2 no-define color-tests parallel-tests tar-ustar])
 
21
 AM_SILENT_RULES([yes])
 
22
+AM_PROG_AR
 
23
 
 
24
 dnl we told automake to not define these, since we want to include
 
25
 dnl the date in the version
 
26
diff --git a/libclamav/c++/configure.ac b/libclamav/c++/configure.ac
 
27
index d72dcd1..353a302 100644
 
28
--- a/libclamav/c++/configure.ac
 
29
+++ b/libclamav/c++/configure.ac
 
30
@@ -20,8 +20,9 @@ AC_CONFIG_SRCDIR([llvm/configure])
 
31
 AC_CONFIG_MACRO_DIR([m4])
 
32
 AC_CONFIG_HEADER([clamavcxx-config.h])
 
33
 AC_CANONICAL_TARGET
 
34
-AM_INIT_AUTOMAKE([1.9 -Wall -Wportability -Werror foreign no-define color-tests tar-pax])
 
35
+AM_INIT_AUTOMAKE([-Wall -Wportability -Werror foreign no-define color-tests tar-pax])
 
36
 AM_SILENT_RULES([yes])
 
37
+AM_PROG_AR
 
38
 
 
39
 cxxset=${CXXFLAGS+set}
 
40
 AC_PROG_CXX