~ubuntu-branches/ubuntu/wily/clamav/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0010-allow-to-use-internal-libmspack-if-the-external-is-n.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2015-05-05 14:14:58 UTC
  • mfrom: (0.47.16)
  • Revision ID: package-import@ubuntu.com-20150505141458-mbkr5jjfu3j9gdvd
Tags: 0.98.7+dfsg-0ubuntu1
* Updated to 0.98.7 to fix multiple issues
  - CVE-2015-2170
  - CVE-2015-2221
  - CVE-2015-2222
  - CVE-2015-2305
  - CVE-2015-2668
* Refreshed patches for 0.98.7:
  - d/p/0005-libclamav-use-libmspack.patch
  - d/p/0007-fix-ssize_t-size_t-off_t-printf-modifier.patch
  - d/p/0008-hardcode-LLVM-linker-flag-because-llvm-config-return.patch
  - d/p/0015-llvm-don-t-use-system-libs.patch
* Removed upstreamed patches:
  - d/p/0012-remove-AC_CONFIG_SRCDIR-llvm-configure-from-libclama.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
9
9
 libclamav/Makefile.am | 30 +++++++++++++++++++++++++++++-
10
10
 2 files changed, 43 insertions(+), 3 deletions(-)
11
11
 
12
 
diff --git a/configure.ac b/configure.ac
13
 
index e3ba55b..9a37e09 100644
14
 
--- a/configure.ac
15
 
+++ b/configure.ac
16
 
@@ -131,6 +131,18 @@ m4_include([m4/reorganization/libs/curl.m4])
 
12
Index: clamav-0.98.7+dfsg/configure.ac
 
13
===================================================================
 
14
--- clamav-0.98.7+dfsg.orig/configure.ac        2015-05-04 11:38:18.661384075 -0400
 
15
+++ clamav-0.98.7+dfsg/configure.ac     2015-05-04 11:38:18.661384075 -0400
 
16
@@ -131,6 +131,18 @@
17
17
 
18
18
 m4_include([m4/reorganization/substitutions.m4])
19
19
 
32
32
 AM_CONDITIONAL([ENABLE_CLAMSUBMIT], [test "$have_curl" = "yes"])
33
33
 
34
34
 AC_CONFIG_FILES([
35
 
@@ -178,8 +190,6 @@ fi
 
35
@@ -183,8 +195,6 @@
36
36
 AM_CONDITIONAL([ENABLE_LLVM],
37
37
               [test "$subdirfailed" != "yes" && test "$enable_llvm" != "no"])
38
38
 
41
41
 no_recursion="yes";
42
42
 AC_OUTPUT([libclamav/Makefile])
43
43
 
44
 
@@ -236,6 +246,8 @@ if test "x$PCRE_HOME" = "x"; then
 
44
@@ -245,6 +255,8 @@
45
45
 else
46
46
     CL_MSG_STATUS([pcre        ],[$PCRE_HOME],[$have_pcre])
47
47
 fi
48
48
+CL_MSG_STATUS([preclass    ],[$LIBJSON_HOME],[$have_json])
49
49
+CL_MSG_STATUS([libmspack   ],[yes],[$mspack_msg])
50
50
 if test "x$XML_LIBS" = "x"; then 
51
 
     CL_MSG_STATUS([dmg and xar ],[no],[])
 
51
     CL_MSG_STATUS([libxml2     ],[no],[])
52
52
 else
53
 
diff --git a/libclamav/Makefile.am b/libclamav/Makefile.am
54
 
index 538e83d..6d2cf92 100644
55
 
--- a/libclamav/Makefile.am
56
 
+++ b/libclamav/Makefile.am
57
 
@@ -122,11 +122,12 @@ libclamav_internal_utils_nothreads_la_SOURCES=str.c\
 
53
Index: clamav-0.98.7+dfsg/libclamav/Makefile.am
 
54
===================================================================
 
55
--- clamav-0.98.7+dfsg.orig/libclamav/Makefile.am       2015-05-04 11:38:18.661384075 -0400
 
56
+++ clamav-0.98.7+dfsg/libclamav/Makefile.am    2015-05-04 11:38:18.661384075 -0400
 
57
@@ -122,11 +122,12 @@
58
58
 libclamav_internal_utils_nothreads_la_LDFLAGS=-static @SSL_LDFLAGS@ @JSON_LDFLAGS@
59
59
 libclamav_internal_utils_nothreads_la_CFLAGS=$(AM_CFLAGS) -DCL_NOTHREADS @SSL_CPPFLAGS@ @JSON_CPPFLAGS@
60
60
 libclamav_internal_utils_nothreads_la_LIBADD=@SSL_LIBS@ @JSON_LIBS@
68
68
 else
69
69
 LLVMLIBADD=libclamav_nocxx.la
70
70
 LLVMDEP=libclamav_nocxx.la
71
 
@@ -147,8 +148,35 @@ if VERSIONSCRIPT
 
71
@@ -147,8 +148,35 @@
72
72
 libclamav_la_LDFLAGS += -Wl,@VERSIONSCRIPTFLAG@,@top_srcdir@/libclamav/libclamav.map
73
73
 endif
74
74