~ubuntu-branches/ubuntu/wily/codelite/wily

« back to all changes in this revision

Viewing changes to debian/patches/03_move-helper-binaries.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chow Loong Jin
  • Date: 2010-01-24 20:14:16 UTC
  • Revision ID: james.westby@ubuntu.com-20100124201416-oxvblu8agqb2uo7q
Tags: 2.1.0.3584+dfsg-0ubuntu2
* debian/patches/03_move-helper-binaries:
  + Fix codelite_indexer path. Was not properly patched before (LP: #511375)
* debian/control:
  + Set Maintainer to Ubuntu Developers, move my name to XSBC-Original-Maintainer

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: codelite/LiteEditor/manager.cpp
2
2
===================================================================
3
 
--- codelite.orig/LiteEditor/manager.cpp        2010-01-11 03:38:59.669965112 +0800
4
 
+++ codelite/LiteEditor/manager.cpp     2010-01-11 03:59:41.879982317 +0800
 
3
--- codelite.orig/LiteEditor/manager.cpp        2010-01-24 19:42:27.227636741 +0800
 
4
+++ codelite/LiteEditor/manager.cpp     2010-01-24 19:42:27.257637123 +0800
5
5
@@ -1192,7 +1192,7 @@
6
6
                if ( bldConf->GetPauseWhenExecEnds() ) {
7
7
                        wxString ld_lib_path;
13
13
                                command << wxT ( "/bin/sh -f " ) << exeWrapper.GetFullPath() << wxT ( " LD_LIBRARY_PATH=" ) << ld_lib_path << wxT ( " " );
14
14
Index: codelite/LiteEditor/frame.cpp
15
15
===================================================================
16
 
--- codelite.orig/LiteEditor/frame.cpp  2010-01-11 03:48:21.949963195 +0800
17
 
+++ codelite/LiteEditor/frame.cpp       2010-01-11 04:00:48.399985030 +0800
18
 
@@ -748,7 +748,7 @@
19
 
        tagsManager->SetCodeLiteIndexerPath(wxStandardPaths::Get().GetDataDir());
 
16
--- codelite.orig/LiteEditor/frame.cpp  2010-01-24 19:45:06.500193479 +0800
 
17
+++ codelite/LiteEditor/frame.cpp       2010-01-24 19:46:04.377663608 +0800
 
18
@@ -749,7 +749,7 @@
20
19
 #else
21
20
        // set the path to codelite_indexer
22
 
-       wxFileName exePath( wxStandardPaths::Get().GetExecutablePath() );
23
 
+       wxFileName exePath( wxStandardPaths::Get().GetPluginsDir() );
24
 
        tagsManager->SetCodeLiteIndexerPath(exePath.GetPath());
 
21
        wxFileName exePath( wxStandardPaths::Get().GetExecutablePath() );
 
22
-       tagsManager->SetCodeLiteIndexerPath(exePath.GetPath());
 
23
+       tagsManager->SetCodeLiteIndexerPath(wxStandardPaths::Get().GetPluginsDir());
25
24
        ManagerST::Get()->SetCodeLiteLauncherPath(exePath.GetPath());
26
25
 #endif
 
26
        tagsManager->StartCtagsProcess();
27
27
Index: codelite/cppchecker/cppcheckjob.cpp
28
28
===================================================================
29
 
--- codelite.orig/cppchecker/cppcheckjob.cpp    2010-01-11 04:02:26.692463248 +0800
30
 
+++ codelite/cppchecker/cppcheckjob.cpp 2010-01-11 04:05:01.982542405 +0800
 
29
--- codelite.orig/cppchecker/cppcheckjob.cpp    2010-01-24 19:42:25.780137034 +0800
 
30
+++ codelite/cppchecker/cppcheckjob.cpp 2010-01-24 19:42:27.267649007 +0800
31
31
@@ -148,8 +148,7 @@
32
32
 #if defined (__WXMAC__)
33
33
        path = wxStandardPaths::Get().GetDataDir();
40
40
        path << wxFileName::GetPathSeparator() << wxT("codelite_cppcheck");
41
41
Index: codelite/Plugin/pipedprocess.cpp
42
42
===================================================================
43
 
--- codelite.orig/Plugin/pipedprocess.cpp       2010-01-11 04:09:37.869964325 +0800
44
 
+++ codelite/Plugin/pipedprocess.cpp    2010-01-11 04:10:40.682585785 +0800
 
43
--- codelite.orig/Plugin/pipedprocess.cpp       2010-01-24 19:42:25.770143868 +0800
 
44
+++ codelite/Plugin/pipedprocess.cpp    2010-01-24 19:42:27.267649007 +0800
45
45
@@ -54,8 +54,7 @@
46
46
 {
47
47
 #ifdef __WXGTK__