~ubuntu-branches/ubuntu/wily/dolfin/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/workaround-boost-error.patch

  • Committer: Package Import Robot
  • Author(s): Johannes Ring
  • Date: 2014-09-22 14:35:34 UTC
  • mfrom: (1.1.17) (19.1.23 sid)
  • Revision ID: package-import@ubuntu.com-20140922143534-0yi89jyuqbgdxwm9
Tags: 1.4.0+dfsg-4
* debian/control: Disable libcgal-dev on i386, mipsel and sparc.
* debian/rules: Remove bad directives in pkg-config file dolfin.pc
  (closes: #760658).
* Remove debian/libdolfin-dev.lintian-overrides.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Workaround compile error with boost by including stdint.h
2
 
 I got a build failure with the error
3
 
 
4
 
 In file included from /usr/include/boost/atomic.hpp:12:0,
5
 
                  from /usr/include/boost/thread/pthread/once_atomic.hpp:20,
6
 
                  from /usr/include/boost/thread/once.hpp:20,
7
 
                  from /usr/include/boost/thread.hpp:17,
8
 
                  from /dolfin-1.3.0+dfsg/dolfin/log/Logger.cpp:32:
9
 
 /usr/include/boost/atomic/atomic.hpp:202:16: error: ‘uintptr_t’ was not declared in this scope
10
 
 /usr/include/boost/atomic/atomic.hpp:202:25: error: template argument 1 is invalid
11
 
 /usr/include/boost/atomic/atomic.hpp:202:43: error: invalid type in declaration before ‘;’ token
12
 
 
13
 
 From some googling it seemed the workaround was to include stdint.h before
14
 
 including the boost headers, so I did that.
15
 
Author: Peter Michael Green <plugwash@debian.org>
16
 
 
17
 
---
18
 
The information above should follow the Patch Tagging Guidelines, please
19
 
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
20
 
are templates for supplementary fields that you might want to add:
21
 
 
22
 
Origin: <vendor|upstream|other>, <url of original patch>
23
 
Bug: <url in upstream bugtracker>
24
 
Bug-Debian: http://bugs.debian.org/<bugnumber>
25
 
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
26
 
Forwarded: <no|not-needed|url proving that it has been forwarded>
27
 
Reviewed-By: <name and email of someone who approved the patch>
28
 
Last-Update: <YYYY-MM-DD>
29
 
 
30
 
--- dolfin-1.3.0+dfsg.orig/dolfin/log/Logger.cpp
31
 
+++ dolfin-1.3.0+dfsg/dolfin/log/Logger.cpp
32
 
@@ -29,6 +29,8 @@
33
 
 #include <stdexcept>
34
 
 #include <string>
35
 
 
36
 
+#include <stdint.h>
37
 
+
38
 
 #include <boost/thread.hpp>
39
 
 #include <boost/bind.hpp>
40
 
 #include <boost/date_time/posix_time/posix_time.hpp>