~ubuntu-branches/ubuntu/wily/dovecot/wily

« back to all changes in this revision

Viewing changes to debian/patches/postgres_configure.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): CHuck Short, Chuck Short
  • Date: 2009-11-06 00:47:29 UTC
  • mfrom: (4.1.9 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091106004729-i39n7v9e7d4h51f6
Tags: 1:1.2.6-1ubuntu1
* Merge from debian testing, remaining changes:
  Add new binary pkg dovecot-postfix that integrates postfix and dovecot
  automatically: (LP: #164837)
  + debian/control:
    - add new binary with short description
    - set Architecture all for dovecot-postfix (LP: #329878)
  + debian/dovecot-postfix.postinst:
    - create initial certificate symlinks to snakeoil.
    - set up postfix with postconf to:
      - use Maildir/ as the default mailbox.
      - use dovecot as the sasl authentication server.
      - use dovecot LDA (deliver).
      - use tls for smtp{d} services.
    - fix certificates paths in postfix' main.cf
    - add reject_unauth_destination to postfix' recipient restrictions
    - add reject_unknown_sender_domain to postfix' sender restrictions
    - rename configuration name on remove, delete on purge
    - restart dovecot after linking certificates
    - handle use case when postfix is unconfigurated
   + debian/dovecot-postfix.dirs: create backup directory for postfix's configuration
   + restart postfix and dovecot.
   + debian/dovecot-postfix.postrm:
     - remove all dovecot related configuration from postfix.
     - restart postfix and dovecot.
   + debian/dovecot-common.init:
     - check if /etc/dovecot/dovecot-postfix.conf exists and use it
       as the configuration file if so.
   + debian/patches/warning-ubuntu-postfix.dpatch
     - add warning about dovecot-postfix.conf in dovecot default 
       configuration file
   + debian/patches/dovecot-postfix.conf.diff:
     - Ubuntu server custom changes to the default dovecot configuration for
       better interfation with postfix
     - enable sieve plugin
   + debian/patches/dovecot-postfix.conf.diff:
     + Ubuntu server custom changes to the default dovecot configuration for
       better integration with postfix:
       - enable imap, pop3, imaps, pop3s and managesieve by default.
       - enable dovecot LDA (deliver).
       - enable SASL auth socket in postfix private directory.
   + debian/rules:
     - copy, patch and install dovecot-postfix.conf in /etc/dovecot/.
     - build architecure independent packages too
   + Use Snakeoil SSL certificates by default.
     - debian/control: Depend on ssl-cert.
     - debian/patches/ssl-cert-snakeoil.dpatch: Change default SSL cert
       paths to snakeoil.
     - debian/dovecot-common.postinst: Relax grep for SSL_* a bit.
   + Add autopkgtest to debian/tests/*.
   + Fast TearDown: Update the lsb init header to not stop in level 6.
   + Add ufw integration:
     - Created debian/dovecot-common.ufw.profile.
     - debian/rules:
       + install profile
     - debian/control:
       + Suggest ufw
   + debian/{control,rules}: enable PIE hardening.
   + dovecot-imapd, dovecot-pop3: Replaces dovecot-common (<< 1:1.1). LP: #254721
   + debian/control:
     - Update Vcs-* headers.
   + debian/rules:
     - Create emtpy stamp.h.in files in dovecot-sieve/ and dovecot-managesieve/
       if they're not there since empty files are not included in the diff.gz 
       file.
   + Add SMTP-AUTH support for Outlook (login auth mechanism)
   + Dropped:
     - debian/patches/security-CVE-2009-3235: Applied upstream.
     - debian/patches/fix-pop3-assertion.dpatch: Applied upstream.
     - dovecot-sieve and dovecot-managesieve: Use the debian patches instead.

  [Chuck Short]
  - Updated dovecot-sieve to 0.1.13.
  - Updated dovecot-managesieve to 0.11.9.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
## DP: Make configure use pg_config  if it is available.
4
 
## DP: Author: Jaldhar H. Vyas <jaldhar@debian.org>
5
 
 
6
 
. $(dirname $0)/DPATCH
7
 
 
8
 
exit 0
9
 
@DPATCH@
10
 
diff -urN dovecot-1.1.1/configure.in dovecot-1.1.1-postgres/configure.in
11
 
--- dovecot-1.1.1/configure.in  2008-06-22 05:02:27.000000000 -0600
12
 
+++ dovecot-1.1.1-postgres/configure.in 2008-06-23 22:04:39.000000000 -0600
13
 
@@ -1807,21 +1807,29 @@
14
 
 fi
15
 
 
16
 
 if test $want_pgsql != no; then
17
 
-       # based on code from PHP
18
 
-       for i in /usr /usr/local /usr/local/pgsql; do
19
 
-               for j in include include/pgsql include/postgres include/postgresql ""; do
20
 
-                       if test -r "$i/$j/libpq-fe.h"; then
21
 
-                               PGSQL_INCLUDE=$i/$j
22
 
-                       fi
23
 
+       PGSQL_INCLUDE="`pg_config --includedir`"
24
 
+       if test "$PGSQL_INCLUDE" = ""; then
25
 
+               # based on code from PHP
26
 
+               for i in /usr /usr/local /usr/local/pgsql; do
27
 
+                       for j in include include/pgsql include/postgres include/postgresql ""; do
28
 
+                               if test -r "$i/$j/libpq-fe.h"; then
29
 
+                                       PGSQL_INCLUDE=$i/$j
30
 
+                               fi
31
 
+                       done
32
 
                done
33
 
-               for lib in lib lib64; do
34
 
-                 for j in $lib $lib/pgsql $lib/postgres $lib/postgresql ""; do
35
 
-                       if test -f "$i/$j/libpq.so" || test -f "$i/$j/libpq.a"; then
36
 
-                               PGSQL_LIBDIR=$i/$j
37
 
-                       fi
38
 
-                 done
39
 
+       fi
40
 
+       PGSQL_LIBDIR="`pg_config --libdir`"
41
 
+       if test "$PGSQL_LIBDIR" = ""; then
42
 
+               for i in /usr /usr/local /usr/local/pgsql; do
43
 
+                       for lib in lib lib64; do
44
 
+                         for j in $lib $lib/pgsql $lib/postgres $lib/postgresql ""; do
45
 
+                               if test -f "$i/$j/libpq.so" || test -f "$i/$j/libpq.a"; then
46
 
+                                       PGSQL_LIBDIR=$i/$j
47
 
+                               fi
48
 
+                         done
49
 
+                       done
50
 
                done
51
 
-       done
52
 
+       fi
53
 
 
54
 
        old_LIBS=$LIBS
55
 
        if test "$PGSQL_LIBDIR" != ""; then