~ubuntu-branches/ubuntu/wily/ecasound/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0003-build-shared-libecasound.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alessandro Ghedini, Alessio Treglia, Alessandro Ghedini
  • Date: 2011-05-24 16:27:44 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20110524162744-yn785q5e27yz2l93
Tags: 2.8.1-1
[ Alessio Treglia ]
* New upstream release.
* Disable alsa on non-linux archs.

[ Alessandro Ghedini ]
* Remove libecasound23, libecasound-dev and libecasound2.2-dev packages
  - Drop build-shared-libecasound patch
* Drop handle_estrpipe patch (merged upstream)
* Fix libkvutils4 section (libs, not libedevel)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Alessandro Ghedini <al3xbio@gmail.com>
2
 
Date: Sun, 6 Feb 2011 18:55:33 +0100
3
 
Subject: [PATCH] build shared libecasound
4
 
 
5
 
Build libecasound as shared library instead of static
6
 
---
7
 
 libecasound/Makefile.am         |    2 +-
8
 
 libecasound/Makefile.in         |    2 +-
9
 
 libecasound/plugins/Makefile.am |    2 +-
10
 
 libecasound/plugins/Makefile.in |    2 +-
11
 
 4 files changed, 4 insertions(+), 4 deletions(-)
12
 
 
13
 
--- a/libecasound/Makefile.am
14
 
+++ b/libecasound/Makefile.am
15
 
@@ -364,7 +364,7 @@
16
 
 
17
 
 libecasound_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
18
 
 libecasound_debug_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
19
 
-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
20
 
+libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -shared -fPIC
21
 
 libecasound_la_LIBADD = $(eca_libadd)
22
 
 libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
23
 
 libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)
24
 
--- a/libecasound/Makefile.in
25
 
+++ b/libecasound/Makefile.in
26
 
@@ -708,7 +708,7 @@
27
 
 
28
 
 libecasound_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
29
 
 libecasound_debug_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
30
 
-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
31
 
+libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -shared -fPIC
32
 
 libecasound_la_LIBADD = $(eca_libadd)
33
 
 libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
34
 
 libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)
35
 
--- a/libecasound/plugins/Makefile.am
36
 
+++ b/libecasound/plugins/Makefile.am
37
 
@@ -105,7 +105,7 @@
38
 
 libecasound_plugins_la_SOURCES          = audioio_dummy.cpp $(plugin_cond_sources)
39
 
 EXTRA_libecasound_plugins_la_SOURCES    = $(plugin_all_sources)
40
 
 libecasound_plugins_la_LIBADD          = $(ECA_S_EXTRA_LIBS)
41
 
-libecasound_plugins_la_LDFLAGS                 = -static
42
 
+libecasound_plugins_la_LDFLAGS                 = -shared -fPIC
43
 
 
44
 
 libecasound_plugins_debug_la_SOURCES   = $(libecasound_plugins_la_SOURCES)
45
 
 EXTRA_libecasound_plugins_debug_la_SOURCES = $(EXTRA_libecasound_plugins_la_SOURCES)
46
 
--- a/libecasound/plugins/Makefile.in
47
 
+++ b/libecasound/plugins/Makefile.in
48
 
@@ -328,7 +328,7 @@
49
 
 libecasound_plugins_la_SOURCES = audioio_dummy.cpp $(plugin_cond_sources)
50
 
 EXTRA_libecasound_plugins_la_SOURCES = $(plugin_all_sources)
51
 
 libecasound_plugins_la_LIBADD = $(ECA_S_EXTRA_LIBS)
52
 
-libecasound_plugins_la_LDFLAGS = -static
53
 
+libecasound_plugins_la_LDFLAGS = -shared -fPIC
54
 
 libecasound_plugins_debug_la_SOURCES = $(libecasound_plugins_la_SOURCES)
55
 
 EXTRA_libecasound_plugins_debug_la_SOURCES = $(EXTRA_libecasound_plugins_la_SOURCES)
56
 
 libecasound_plugins_debug_la_LIBADD = $(libecasound_plugins_la_LIBADD)