~ubuntu-branches/ubuntu/wily/gedit-valencia-plugin/wily

« back to all changes in this revision

Viewing changes to debian/patches/build-against-gedit38.patch

  • Committer: Package Import Robot
  • Author(s): Robert Ancell
  • Date: 2015-06-16 10:30:06 UTC
  • mfrom: (1.1.2)
  • Revision ID: package-import@ubuntu.com-20150616103006-g0kvnqr2wa3bnvxf
Tags: 0.8.0-0ubuntu1
* New upstream release
* debian/control:
  - Bump build-depends on gedit-dev, libvala-0.24-dev, valac-0.24,
    libgee-0.8-dev
  - Add missing build-depends on libgtksourceview-3.0-dev
* debian/watch:
  - Update to GNOME location (LP: #1251052)
* debian/patches/build-against-gedit38.patch:
  - Applied upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From bfb45d5c6da8bd0c78d8f10d07aa2c4c50a33662 Mon Sep 17 00:00:00 2001
2
 
From: Michel Alexandre Salim <salimma@fedoraproject.org>
3
 
Date: Sat, 20 Apr 2013 00:00:00 +0000
4
 
Subject: Does not build against gedit 3.7.5: Closes #6505
5
 
 
6
 
Also updates Valencia to require Vala 0.20.1.
7
 
---
8
 
diff --git a/Makefile b/Makefile
9
 
index c4a6d76..0760ed3 100644
10
 
--- a/Makefile
11
 
+++ b/Makefile
12
 
@@ -5,21 +5,20 @@ VERSION = 0.4.0+trunk
13
 
 
14
 
 VALAC = valac
15
 
 VALAC_VERSION := `$(VALAC) --version | awk '{print $$2}'`
16
 
-MIN_VALAC_VERSION := 0.17.1
17
 
-MAX_VALAC_VERSION := 0.19.0
18
 
+MIN_VALAC_VERSION := 0.20.1
19
 
 
20
 
 SOURCES = autocomplete.vala browser.vala expression.vala gtk_util.vala parser.vala program.vala \
21
 
           scanner.vala settings.vala util.vala valencia.vala
22
 
  
23
 
 PACKAGES = --pkg gedit --pkg gee-1.0 --pkg gtk+-3.0 --pkg gtksourceview-3.0 \
24
 
-           --pkg libpeas-1.0 --pkg libvala-0.18 --pkg vte-2.90
25
 
+           --pkg libpeas-1.0 --pkg libvala-0.20 --pkg vte-2.90
26
 
 
27
 
 PACKAGE_VERSIONS = \
28
 
     gedit >= 2.91.0 \
29
 
     gee-1.0 >= 0.1.3 \
30
 
     gtksourceview-3.0 >= 3.0.0 \
31
 
     gtk+-3.0 >= 3.0.0 \
32
 
-    libvala-0.18 >= 0.17.1 \
33
 
+    libvala-0.20 >= 0.20.1 \
34
 
     vte-2.90 >= 0.27.90
35
 
 
36
 
 OUTPUTS = libvalencia.so valencia.plugin
37
 
diff --git a/gtk_util.vala b/gtk_util.vala
38
 
index ae26e8f..ba7b22a 100644
39
 
--- a/gtk_util.vala
40
 
+++ b/gtk_util.vala
41
 
@@ -521,7 +521,8 @@ string? document_filename(Gedit.Document document) {
42
 
 Gedit.Tab? find_tab(string filename, out Gedit.Window window) {
43
 
     File location = File.new_for_path(filename);
44
 
     
45
 
-    foreach (Gedit.Window w in Gedit.App.get_default().get_windows()) {
46
 
+    foreach (Gtk.Window gtk_w in ((Gedit.App) Application.get_default()).get_windows()) {
47
 
+        Gedit.Window w = (Gedit.Window) gtk_w;
48
 
         Gedit.Tab tab = w.get_tab_from_location(location);
49
 
         if (tab != null) {
50
 
             window = w;
51
 
diff --git a/valencia.vala b/valencia.vala
52
 
index 1f0dbe6..2ed18af 100644
53
 
--- a/valencia.vala
54
 
+++ b/valencia.vala
55
 
@@ -739,7 +739,7 @@ public class Instance : Peas.ExtensionBase, Gedit.WindowActivatable {
56
 
     }
57
 
     
58
 
     void on_build() {
59
 
-        foreach (Gedit.Document d in Gedit.App.get_default().get_documents())
60
 
+        foreach (Gedit.Document d in ((Gedit.App) Application.get_default()).get_documents())
61
 
             if (!d.is_untitled() && d.get_modified()) {
62
 
                 ++saving;
63
 
                 Signal.connect(d, "saved", (Callback) saved_callback, this);
64
 
@@ -917,7 +917,7 @@ public class Instance : Peas.ExtensionBase, Gedit.WindowActivatable {
65
 
     public void reparse_modified_documents(string filename) {
66
 
         Program program = Program.find_containing(filename, true);
67
 
 
68
 
-        foreach (Gedit.Document document in Gedit.App.get_default().get_documents()) {
69
 
+        foreach (Gedit.Document document in ((Gedit.App) Application.get_default()).get_documents()) {
70
 
             assert(documents_modified_state.has_key(document));
71
 
             bool previously_modified = documents_modified_state.get(document);
72
 
             bool currently_modified = document.get_modified();
73