~ubuntu-branches/ubuntu/wily/glusterfs/wily

« back to all changes in this revision

Viewing changes to debian/patches/02-spelling-error.diff

  • Committer: Clint Byrum
  • Date: 2012-11-07 17:45:49 UTC
  • mfrom: (20.1.7 sid)
  • Revision ID: clint@ubuntu.com-20121107174549-x6atqx0rsd7ht0q5
Tags: 3.2.7-2ubuntu1
* Merge from Debian unstable. Remaining changes:
  - Added Ubuntu upstart jobs providing support for local glusterfs mounts
* Add upstream patch 03-glusterd-crash-gcc-optimizations, which fixes a crash
  of glusterd on submitting a command like create/delete volume to it. This
  happens with GCC 4.7 and -O2, where GCC optimizes out rsp statements.
  Closes: #679767
* New upstream release.
* New upstream pre release.
* Updated debian packaging copyright file
  - Fixed upstream project URLs and information
* Correct e-mail address from Matthias.
* New upstream pre release.
  - Refresh hunky patch 02-spelling-error.
* New upstream release.
  - Drop merged patch 03-hardened-gf-log.
  - Refresh hunky patch 02-spelling-error.
* Wrap all debian/control fields.
* Remove unused lintian overrides.
* Bump Standards-Version to 3.9.3 (no changes needed).
* Override lintian warnings about shlibs-calls-exit.
* Fix lintian warning vim-addon-within-vim-runtime-path by installing
  glusterfs.vim as example file now.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
# Fix spelling errors in source code.
2
2
 
3
 
diff -Naur glusterfs-3.2.3.orig/ChangeLog glusterfs-3.2.3/ChangeLog
4
 
--- glusterfs-3.2.3.orig/ChangeLog      2011-08-23 14:31:42.000000000 +0200
5
 
+++ glusterfs-3.2.3/ChangeLog   2011-08-26 21:29:29.000000000 +0200
6
 
@@ -20852,7 +20852,7 @@
 
3
diff -Naur glusterfs-3.2.7qa1.orig/ChangeLog glusterfs-3.2.7qa1/ChangeLog
 
4
--- glusterfs-3.2.7qa1.orig/ChangeLog   2012-04-12 19:21:25.000000000 +0200
 
5
+++ glusterfs-3.2.7qa1/ChangeLog        2012-06-05 19:46:00.837068721 +0200
 
6
@@ -22917,7 +22917,7 @@
7
7
       - change signature of rpc_clnt_submit to accept rsphdr_vector and
8
8
         rsppayload_vector. The buffers pointed by these vectors will be
9
9
         from iobufs and these iobufs are added to an iobref which should
12
12
     
13
13
     Signed-off-by: Raghavendra G <raghavendra@gluster.com>
14
14
     Signed-off-by: Anand V. Avati <avati@dev.gluster.com>
15
 
@@ -27051,7 +27051,7 @@
 
15
@@ -29116,7 +29116,7 @@
16
16
 Author: Raghavendra G <raghavendra@gluster.com>
17
17
 Date:   Thu Dec 3 21:47:23 2009 +0000
18
18
 
21
21
     
22
22
     - since sp_process_inode_ctx is called by many fops, if the context is not
23
23
         set "caller" argument can be logged in log msgs to identify caller.
24
 
@@ -27507,7 +27507,7 @@
 
24
@@ -29572,7 +29572,7 @@
25
25
 Author: Raghavendra G <raghavendra@gluster.com>
26
26
 Date:   Wed Dec 2 12:29:56 2009 +0000
27
27
 
30
30
     
31
31
     - @inode in sp_lookup_cbk may be NULL in case of failure of lookup.
32
32
     
33
 
@@ -28955,7 +28955,7 @@
 
33
@@ -31020,7 +31020,7 @@
34
34
 
35
35
     libglusterfsclient: change the prototype of glusterfs_lsetxattr.
36
36
     
39
39
         in the vmp table based on the path.
40
40
     
41
41
     Signed-off-by: Raghavendra G <raghavendra@gluster.com>
42
 
@@ -39859,7 +39859,7 @@
 
42
@@ -41924,7 +41924,7 @@
43
43
 Author: Raghavendra G <raghavendra@zresearch.com>
44
44
 Date:   Tue Apr 14 02:53:09 2009 -0700
45
45
 
48
48
     
49
49
     Signed-off-by: Anand V. Avati <avati@amp.gluster.com>
50
50
 
51
 
diff -Naur glusterfs-3.2.3.orig/libglusterfs/src/common-utils.c glusterfs-3.2.3/libglusterfs/src/common-utils.c
52
 
--- glusterfs-3.2.3.orig/libglusterfs/src/common-utils.c        2011-08-23 14:31:37.000000000 +0200
53
 
+++ glusterfs-3.2.3/libglusterfs/src/common-utils.c     2011-08-26 21:29:29.000000000 +0200
 
51
diff -Naur glusterfs-3.2.7qa1.orig/libglusterfs/src/common-utils.c glusterfs-3.2.7qa1/libglusterfs/src/common-utils.c
 
52
--- glusterfs-3.2.7qa1.orig/libglusterfs/src/common-utils.c     2012-04-12 19:21:20.000000000 +0200
 
53
+++ glusterfs-3.2.7qa1/libglusterfs/src/common-utils.c  2012-06-05 19:46:00.841068429 +0200
54
54
@@ -451,7 +451,7 @@
55
55
         int j = 0;
56
56
 
168
168
                 return -1;
169
169
         }
170
170
 
171
 
@@ -1721,7 +1721,7 @@
 
171
@@ -1735,7 +1735,7 @@
172
172
         int length = 0;
173
173
 
174
174
         if (address == NULL) {
177
177
                 goto out;
178
178
         }
179
179
 
180
 
diff -Naur glusterfs-3.2.3.orig/rpc/rpc-lib/src/rpcsvc.c glusterfs-3.2.3/rpc/rpc-lib/src/rpcsvc.c
181
 
--- glusterfs-3.2.3.orig/rpc/rpc-lib/src/rpcsvc.c       2011-08-23 14:31:38.000000000 +0200
182
 
+++ glusterfs-3.2.3/rpc/rpc-lib/src/rpcsvc.c    2011-08-26 21:29:29.000000000 +0200
 
180
diff -Naur glusterfs-3.2.7qa1.orig/rpc/rpc-lib/src/rpcsvc.c glusterfs-3.2.7qa1/rpc/rpc-lib/src/rpcsvc.c
 
181
--- glusterfs-3.2.7qa1.orig/rpc/rpc-lib/src/rpcsvc.c    2012-04-12 19:21:21.000000000 +0200
 
182
+++ glusterfs-3.2.7qa1/rpc/rpc-lib/src/rpcsvc.c 2012-06-05 19:46:00.841068429 +0200
183
183
@@ -194,7 +194,7 @@
184
184
 
185
185