~ubuntu-branches/ubuntu/wily/julia/wily

« back to all changes in this revision

Viewing changes to debian/patches/fix-cpu-detection.patch

  • Committer: Package Import Robot
  • Author(s): Sébastien Villemot
  • Date: 2013-02-06 17:54:29 UTC
  • mfrom: (1.1.3)
  • Revision ID: package-import@ubuntu.com-20130206175429-13br5kqpkfjqdmre
Tags: 0.0.0+20130206.git32ff5759-1
* New upstream snapshot.
* debian/copyright: reflect upstream changes
* debian/rules: update get-orig-source to reflect upstream changes
   + Don't ship nginx
   + Adapt for new configure-random target in deps/Makefile
* Enable build of Tk wrapper.
   + debian/control: add build dependency on tk-dev
   + debian/rules: add tk rule to build-arch
* debian/julia.install: install VERSION and COMMIT files
* no-webrepl.patch: new patch
* Refresh other patches
* Add source override for config.status file under deps/random/

Show diffs side-by-side

added added

removed removed

Lines of Context:
22
22
 
23
23
--- a/Make.inc
24
24
+++ b/Make.inc
25
 
@@ -40,12 +40,7 @@
 
25
@@ -43,12 +43,7 @@
26
26
 # Figure out OS and architecture
27
27
 BUILD_OS = $(shell uname)
28
28
 OS = $(BUILD_OS)
36
36
 
37
37
 USE_MKL = 0
38
38
 MKLLIB = /path/to/mkl/lib/intel64
39
 
@@ -95,7 +90,7 @@
 
39
@@ -105,7 +100,7 @@
40
40
 JCXXFLAGS = -pipe $(fPIC) -fno-rtti
41
41
 DEBUGFLAGS = -ggdb3 -DDEBUG
42
42
 SHIPFLAGS = -DNDEBUG -falign-functions
47
47
 endif
48
48
--- a/deps/Makefile
49
49
+++ b/deps/Makefile
50
 
@@ -513,7 +513,7 @@
 
50
@@ -539,7 +539,7 @@
51
51
 LIBRANDOM_CFLAGS = $(CFLAGS) -finline-functions -fomit-frame-pointer -DNDEBUG -fno-strict-aliasing \
52
52
                                   --param max-inline-insns-single=1800 -Wmissing-prototypes -Wall  -std=c99 \
53
53
                                   -DDSFMT_MEXP=19937 $(fPIC) -shared -DDSFMT_DO_NOT_USE_OLD_NAMES