~ubuntu-branches/ubuntu/wily/libgrip/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/lp872022-disconnect-non-toplevel-signal.patch

  • Committer: Package Import Robot
  • Author(s): Stephen M. Webb
  • Date: 2012-05-30 12:25:44 UTC
  • Revision ID: package-import@ubuntu.com-20120530122544-f0j88u8dnkkcesw7
Tags: 0.3.4-0ubuntu2
* updated to standards-version 3.9.3
  - debian/changelog: used official URL
* Fixed a segfault when starting eog under some circumstances (lp: #872022).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fixed a segfault caused by dereferencing a deleted object.
 
2
Origin: commit, revision id: stephen.webb@canonical.com-20120530154230-49g3ii7zd9gz1ew6
 
3
Author: Stephen M. Webb <stephen.webb@canonical.com>
 
4
Bug: https://launchpad.net/bugs/872022
 
5
Last-Update: 2012-05-30
 
6
X-Bzr-Revision-Id: stephen.webb@canonical.com-20120530154230-49g3ii7zd9gz1ew6
 
7
 
 
8
=== modified file 'src/gripgesturemanager.c'
 
9
--- a/src/gripgesturemanager.c
 
10
+++ b/src/gripgesturemanager.c
 
11
@@ -1253,12 +1253,12 @@
 
12
       GtkWidget *toplevel = gtk_widget_get_toplevel (widget);
 
13
       GripRegistrationRequest *req = (GripRegistrationRequest *)user_data;
 
14
 
 
15
+      g_signal_handlers_disconnect_by_func (widget,
 
16
+                                            G_CALLBACK (toplevel_notify_cb),
 
17
+                                            user_data);
 
18
+
 
19
       if (gtk_widget_is_toplevel (toplevel))
 
20
         {
 
21
-          g_signal_handlers_disconnect_by_func (widget,
 
22
-                                                G_CALLBACK (toplevel_notify_cb),
 
23
-                                                user_data);
 
24
-
 
25
           if (gtk_widget_get_mapped (GTK_WIDGET (toplevel)))
 
26
             {
 
27
               register_internal (req->manager,