~ubuntu-branches/ubuntu/wily/libxml2/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0006-fix-python-multiarch-includes.patch

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-03-07 17:03:45 UTC
  • Revision ID: package-import@ubuntu.com-20130307170345-jcinb408mx7g0c73
Tags: 2.9.0+dfsg1-4ubuntu3
* Set PYTHON_LIBS for cross builds.
* Remove explicit build dependency on binutils.
* Configure the udeb --without-python.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
   * Fix python multi-arch includes issues.
6
6
Author: Chris J Arges <chris.j.arges@canonical.com>
7
7
 
8
 
--- a/configure.in
9
 
+++ b/configure.in
10
 
@@ -781,6 +781,10 @@ if test "$with_python" != "no" ; then
 
8
Index: b/configure.in
 
9
===================================================================
 
10
--- a/configure.in      2013-03-07 08:35:01.000000000 +0000
 
11
+++ b/configure.in      2013-03-07 08:35:01.000000000 +0000
 
12
@@ -781,6 +781,10 @@
11
13
     fi
12
14
     if test "$PYTHON_VERSION" != ""
13
15
     then
18
20
        if test -r $with_python/include/python$PYTHON_VERSION/Python.h -a \
19
21
           -d $with_python/lib/python$PYTHON_VERSION/site-packages
20
22
        then
21
 
@@ -812,6 +816,7 @@ if test "$with_python" != "no" ; then
 
23
@@ -812,6 +816,7 @@
22
24
                    PYTHON_SITE_PACKAGES=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib()"`
23
25
            fi
24
26
        fi
26
28
        PYTHON_LIBS=`python$PYTHON_VERSION-config --ldflags`
27
29
     fi
28
30
     if test "$with_python" != ""
29
 
--- a/python/Makefile.am
30
 
+++ b/python/Makefile.am
31
 
@@ -19,7 +19,7 @@ if WITH_PYTHON
 
31
Index: b/python/Makefile.am
 
32
===================================================================
 
33
--- a/python/Makefile.am        2013-03-07 08:35:01.000000000 +0000
 
34
+++ b/python/Makefile.am        2013-03-07 08:35:01.000000000 +0000
 
35
@@ -19,7 +19,7 @@
32
36
 AM_CPPFLAGS = \
33
37
        -I$(top_builddir)/include \
34
38
        -I$(top_srcdir)/include \
37
41
 
38
42
 python_LTLIBRARIES = libxml2mod.la
39
43
 
 
44
Index: b/python/Makefile.in
 
45
===================================================================
 
46
--- a/python/Makefile.in        2013-03-07 09:04:27.763641401 +0000
 
47
+++ b/python/Makefile.in        2013-03-07 09:27:10.600360803 +0000
 
48
@@ -412,7 +412,7 @@
 
49
 @WITH_PYTHON_TRUE@AM_CPPFLAGS = \
 
50
 @WITH_PYTHON_TRUE@     -I$(top_builddir)/include \
 
51
 @WITH_PYTHON_TRUE@     -I$(top_srcdir)/include \
 
52
-@WITH_PYTHON_TRUE@     -I$(PYTHON_INCLUDES)
 
53
+@WITH_PYTHON_TRUE@     $(PYTHON_INCLUDES)
 
54
 
 
55
 @WITH_PYTHON_TRUE@python_LTLIBRARIES = libxml2mod.la
 
56
 @WITH_PYTHON_TRUE@libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c