~ubuntu-branches/ubuntu/wily/libxml2/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0004-link-libxml2mod-first.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2013-07-11 09:31:50 UTC
  • mfrom: (43.2.4 sid)
  • Revision ID: package-import@ubuntu.com-20130711093150-t3vcnrpfqepqt0mp
Tags: 2.9.1+dfsg1-2ubuntu1
* Merged from Debian unstable. Remaining changes:
  - Fix python multi-arch includes issues. 
  - Allow the package to cross-build.
  - Set PYTHON_LIBS for cross builds.
  - Remove explicit build dependency on binutils.
  - Configure the udeb --without-python.
* Dropped patches:
  - CVE-2013-0338.patch: upstream
  - CVE-2013-1969.patch: upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: YunQiang Su <wzssyqa@gmail.com>
2
 
Date: Sun, 28 Oct 2012 03:29:05 +0800
3
 
Subject: link libxml2mod first
4
 
 
5
 
---
6
 
 python/Makefile.am |    4 ++--
7
 
 1 file changed, 2 insertions(+), 2 deletions(-)
8
 
 
9
 
diff --git a/python/Makefile.am b/python/Makefile.am
10
 
index 4a8b5d5..10724ec 100644
11
 
--- a/python/Makefile.am
12
 
+++ b/python/Makefile.am
13
 
@@ -24,8 +24,8 @@ AM_CPPFLAGS = \
14
 
 python_LTLIBRARIES = libxml2mod.la
15
 
 
16
 
 libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c
17
 
-libxml2mod_la_LIBADD  = $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS) -lpython$(PYTHON_VERSION)
18
 
-libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version
19
 
+libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version \
20
 
+                                               $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS) -lpython$(PYTHON_VERSION)
21
 
 
22
 
 BUILT_SOURCES = libxml2-export.c libxml2-py.h libxml2-py.c
23