~ubuntu-branches/ubuntu/wily/mclibs/wily

« back to all changes in this revision

Viewing changes to debian/patches/002-fix-missing-mclibs.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kevin B. McCarty
  • Date: 2006-09-27 14:37:50 UTC
  • Revision ID: james.westby@ubuntu.com-20060927143750-b8lsprszzxzxwnij
Tags: 2005.dfsg-2
* Change deprecated ${Source-Version} in debian/control.d/* to
  ${source:Version} or ${binary:Version} as appropriate.  Therefore
  Build-Depend on dpkg-dev (>= 1.13.19).

* Re-order dependencies of lib*-dev packages such that the corresponding
  lib* package comes last.

* Switch back to use of type-handling, having cernlib-montecarlo Depend
  upon "libisajet758-2-dev | m68k-linux-gnu" instead of merely
  Recommending libisajet758-2-dev.  This ensures that libisajet758-2-dev
  is installed (on non-m68k systems) on upgrades from Sarge if the
  cernlib-montecarlo metapackage is initially installed, while still
  keeping the metapackage installable on m68k.

* New patch 321: minor changes to support gfortran.  Taken from 2006-07-20
  patch of Harald Vogt <hvogt@ifh.de>.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 002-fix-missing-mclibs.dpatch by  <kmccarty@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Deal with several of the MC libs having to be purged from source.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad mclibs-2005.05.09.dfsg~/src/Imakefile mclibs-2005.05.09.dfsg/src/Imakefile
 
9
--- mclibs-2005.05.09.dfsg~/src/Imakefile       1996-12-16 10:08:41.000000000 -0500
 
10
+++ mclibs-2005.05.09.dfsg/src/Imakefile        2006-06-29 14:09:15.024360574 -0400
 
11
@@ -2,7 +2,7 @@
 
12
 #define PassCDebugFlags
 
13
 
 
14
 
 
15
-LIBDIRS= packlib pawlib graflib mathlib geant321 mclibs phtools
 
16
+LIBDIRS= mclibs phtools
 
17
 
 
18
 SUBDIRS= $(LIBDIRS) patchy cfortran
 
19
 
 
20
diff -urNad mclibs-2005.05.09.dfsg~/src/mclibs/Imakefile mclibs-2005.05.09.dfsg/src/mclibs/Imakefile
 
21
--- mclibs-2005.05.09.dfsg~/src/mclibs/Imakefile        1999-05-20 09:30:20.000000000 -0400
 
22
+++ mclibs-2005.05.09.dfsg/src/mclibs/Imakefile 2006-06-29 14:08:23.769355915 -0400
 
23
@@ -2,9 +2,11 @@
 
24
 #define IHaveSubdirs
 
25
 #define PassCDebugFlags
 
26
 
 
27
-
 
28
-LIBDIRS= ariadne cojets eurodec herwig fritiof \ @@\
 
29
-        isajet jetset lepto63 pdf photos pythia
 
30
+/* Pythia and Jetset are not under GPL, so we must remove references
 
31
+   to them and their dependents.  They have already been purged from
 
32
+   Debianized source code.  Also, re-order libs so that dependent ones
 
33
+   come after dependees. */
 
34
+LIBDIRS= cojets eurodec pdf photos herwig isajet
 
35
 
 
36
 SUBDIRS = $(LIBDIRS)
 
37
 
 
38
@@ -12,8 +14,8 @@
 
39
 
 
40
 InstallLibSubdirs($(LIBDIRS))
 
41
 
 
42
-INCLUDEDIRS= ariadne cojets eurodec herwig fritiof \ @@\
 
43
-        isajet jetset lepto63 pdf pythia
 
44
+/* Again, purge Pythia, Jetset and dependents. */
 
45
+INCLUDEDIRS= cojets eurodec herwig isajet pdf
 
46
 
 
47
 InstallIncludeSubdirs($(INCLUDEDIRS))
 
48