~ubuntu-branches/ubuntu/wily/mediatomb/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0008b_gcc_4.7_support.patch

  • Committer: Package Import Robot
  • Author(s): Steve Langasek
  • Date: 2015-08-12 15:51:30 UTC
  • mfrom: (4.1.15 sid)
  • Revision ID: package-import@ubuntu.com-20150812155130-54v3y5zta9oyuejg
Tags: 0.12.1-47-g7ab7616-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - debian/control:
    + Don't build-depend on libmozjs-dev.
  - debian/{mediatomb-daemon.mediatomb.upstart,rules}: Introduce upstart
    support to fix start-on-boot failure.
  - debian/rules: Disable JS support.
* Dropped changes:
  - drop OR depends on abrowser, which last existed in precise.
  - debian/mediatomb-daemon.postinst: no reason this needs an executable
    bit in the source package.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix a FTBFS when using gcc-4.7
2
 
Origin: other, http://pkgs.fedoraproject.org/gitweb/?p=mediatomb.git;a=commitdiff;h=b96e8410
3
 
Last-Update: 2012-03-03
4
 
 
5
 
diff -up ./src/hash/dbo_hash.h.gcc47 ./src/hash/dbo_hash.h
6
 
--- ./src/hash/dbo_hash.h.gcc47 2012-01-14 11:55:22.520261056 -0500
7
 
+++ ./src/hash/dbo_hash.h       2012-01-14 12:01:48.965302982 -0500
8
 
@@ -106,7 +106,7 @@ public:
9
 
     inline bool remove(KT key)
10
 
     {
11
 
         struct dbo_hash_slot<KT, VT> *slot;
12
 
-        if (! search(key, &slot))
13
 
+        if (! this->search(key, &slot))
14
 
             return false;
15
 
         slot->key = deletedKey;
16
 
         slot->value->release();
17
 
@@ -136,7 +136,7 @@ public:
18
 
     inline void put(KT key, zmm::Ref<VT> value)
19
 
     {
20
 
         struct dbo_hash_slot<KT, VT> *slot;
21
 
-        search(key, &slot);
22
 
+        this->search(key, &slot);
23
 
         put(key, (hash_slot_t)slot, value);
24
 
     }
25
 
     void put(KT key, hash_slot_t destSlot, zmm::Ref<VT> value)
26
 
@@ -162,7 +162,7 @@ public:
27
 
     inline zmm::Ref<VT> get(KT key)
28
 
     {
29
 
         struct dbo_hash_slot<KT, VT> *slot;
30
 
-        bool found = search(key, &slot);
31
 
+        bool found = this->search(key, &slot);
32
 
         if (found)
33
 
             return zmm::Ref<VT>(slot->value);
34
 
         else
35
 
@@ -174,7 +174,7 @@ public:
36
 
     inline zmm::Ref<VT> get(KT key, hash_slot_t *destSlot)
37
 
     {
38
 
         struct dbo_hash_slot<KT, VT> **slot = (struct dbo_hash_slot<KT, VT> **)destSlot;
39
 
-        bool found = search(key, slot);
40
 
+        bool found = this->search(key, slot);
41
 
         if (found)
42
 
             return zmm::Ref<VT>((*slot)->value);
43
 
         else
44
 
diff -up ./src/hash/dbr_hash.h.gcc47 ./src/hash/dbr_hash.h
45
 
--- ./src/hash/dbr_hash.h.gcc47 2012-01-14 12:04:43.464643618 -0500
46
 
+++ ./src/hash/dbr_hash.h       2012-01-14 12:05:24.111120552 -0500
47
 
@@ -124,7 +124,7 @@ public:
48
 
     inline bool remove(KT key)
49
 
     {
50
 
         struct dbr_hash_slot<KT> *slot;
51
 
-        if (! search(key, &slot))
52
 
+        if (! this->search(key, &slot))
53
 
             return false;
54
 
         slot->key = deletedKey;
55
 
         int array_slot = slot->array_slot;
56
 
@@ -134,7 +134,7 @@ public:
57
 
             return true;
58
 
         }
59
 
         data_array[array_slot] = data_array[--this->count];
60
 
-        if (! search(data_array[array_slot], &slot))
61
 
+        if (! this->search(data_array[array_slot], &slot))
62
 
         {
63
 
             log_debug("DBR-Hash-Error: (%d; array_slot=%d; count=%d)\n", data_array[array_slot], array_slot, this->count);
64
 
             throw zmm::Exception(_("DBR-Hash-Error: key in data_array not found in hashtable"));
65
 
@@ -146,7 +146,7 @@ public:
66
 
     inline void put(KT key)
67
 
     {
68
 
         struct dbr_hash_slot<KT> *slot;
69
 
-        if (! search(key, &slot))
70
 
+        if (! this->search(key, &slot))
71
 
         {
72
 
 #ifdef TOMBDEBUG
73
 
             if (this->count >= realCapacity)
74
 
@@ -194,7 +194,7 @@ public:
75
 
     inline bool exists(KT key)
76
 
     {
77
 
         struct dbr_hash_slot<KT> *slot;
78
 
-        return search(key, &slot);
79
 
+        return this->search(key, &slot);
80
 
     }
81
 
     
82
 
     /*
83
 
diff -up ./src/hash/dso_hash.h.gcc47 ./src/hash/dso_hash.h
84
 
--- ./src/hash/dso_hash.h.gcc47 2012-01-14 12:13:50.755582375 -0500
85
 
+++ ./src/hash/dso_hash.h       2012-01-14 12:14:42.511463035 -0500
86
 
@@ -100,7 +100,7 @@ public:
87
 
     inline bool remove(zmm::String key)
88
 
     {
89
 
         struct dso_hash_slot<VT> *slot;
90
 
-        if (! search(key, &slot))
91
 
+        if (! this->search(key, &slot))
92
 
             return false;
93
 
         slot->key->release();
94
 
         slot->value->release();
95
 
@@ -112,7 +112,7 @@ public:
96
 
     inline void put(zmm::String key, zmm::Ref<VT> value)
97
 
     {
98
 
         struct dso_hash_slot<VT> *slot;
99
 
-        search(key, &slot);
100
 
+        this->search(key, &slot);
101
 
         put(key, (hash_slot_t)slot, value);
102
 
     }
103
 
     void put(zmm::String key, hash_slot_t destSlot, zmm::Ref<VT> value)
104
 
@@ -141,7 +141,7 @@ public:
105
 
     inline zmm::Ref<VT> get(zmm::String key)
106
 
     {
107
 
         struct dso_hash_slot<VT> *slot;
108
 
-        bool found = search(key, &slot);
109
 
+        bool found = this->search(key, &slot);
110
 
         if (found)
111
 
             return zmm::Ref<VT>(slot->value);
112
 
         else
113
 
@@ -153,7 +153,7 @@ public:
114
 
     inline zmm::Ref<VT> get(zmm::String key, hash_slot_t *destSlot)
115
 
     {
116
 
         struct dso_hash_slot<VT> **slot = (struct dso_hash_slot<VT> **)destSlot;
117
 
-        bool found = search(key, slot);
118
 
+        bool found = this->search(key, slot);
119
 
         if (found)
120
 
             return zmm::Ref<VT>((*slot)->value);
121
 
         else